Save Settings has unlogical behaviour

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
Hans van Buitenen
Posts: 3
Joined: 09 Aug 2019 10:01

Save Settings has unlogical behaviour

Post by Hans van Buitenen » 09 Aug 2019 10:17

Hi, i'm using saved settings to create an browse setup with several tabs, each with the home folder locked.
What i want is, to be able to save this setting and to be able to revert to it when my session becomes messy.
What i've noticed is that XYplorer saves the session to the last file without notice.
When i want to restore my session it would first auto-save and then load the same ruined session.

I would like XYPlore to auto-save to a default session, and leave the explicit saves alone so i know how these sessions look like and do not change all the time.
The idea of saving a session is to store it, not to store something an then have it destroyed by moving along with your work.

Is this possible?

admin
Site Admin
Posts: 48190
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Save Settings has unlogical behavioure

Post by admin » 09 Aug 2019 11:42

Hi and welcome to the club,

here are two options:

1)
Disable the auto-save by unticking
Configuration | General | Startup & Exit | Save Settings | Save settings on exit

2)
Run a throw-away instance using this menu command:
File | Open Throw Away Clone

Don

jupe
Posts: 1250
Joined: 20 Oct 2017 21:14
Location: 1909 x64

Re: Save Settings has unlogical behavioure

Post by jupe » 09 Aug 2019 11:49

Or maybe Tabsets might suit your use case :

https://www.xyplorer.com/release_10.80.php#tabsets
https://www.xyplorer.com/release_10.70.php#tabsets

Or if you desire further features, and are happy to extend XY functionality via 3rd party scripts you could check this out:

viewtopic.php?f=7&t=8691

Also bug reports are for bugs, not for when current features don't match you expectations, use an alternative section for those posts.

Hans van Buitenen
Posts: 3
Joined: 09 Aug 2019 10:01

Re: Save Settings has unlogical behaviour

Post by Hans van Buitenen » 09 Aug 2019 15:04

Thanks, this feature look what i need, i will have a look at it :)

Hans van Buitenen
Posts: 3
Joined: 09 Aug 2019 10:01

Re: Save Settings has unlogical behaviour

Post by Hans van Buitenen » 16 Aug 2019 08:19

Hi, i have been working with it for a while, but i understand little of how this works.
I really like the features of this explorer but the save settings thing is really annoying
I find myself doing: File, Settings special, Load Configuration, Defaults.ini
each time i start a new window, because save settings does not work
The favorites do not save, while an save as does work correctly.
Either i have no clue what i'm doing :veryconfused: or save defaults does not store the favorites (location and highlite) correctly :?:
As far as i get it this saving needs to be tested thoroughly

admin
Site Admin
Posts: 48190
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Save Settings has unlogical behaviour

Post by admin » 19 Aug 2019 12:26

I think you are trying too hard. Simply look at my tip number 1) here: viewtopic.php?p=171758#p171758

Post Reply