Error updating ini on exit

Things you’d like to miss in the future...
Post Reply
Shadow
Posts: 33
Joined: 21 Nov 2009 00:00

Error updating ini on exit

Post by Shadow » 04 Apr 2010 16:36

Just updated to 9 from 8.8 and XY will not update the INI setting...

http://www.qc1a.com/error.jpg

http://www.qc1a.com/ini_status.jpg

edit: OS = Win7

Stefan
Posts: 1360
Joined: 18 Nov 2008 21:47
Location: Germany, EU

Re: Error updating ini on exit

Post by Stefan » 04 Apr 2010 18:34

Hi Shadow, welcome.

I don't work with any UAC-using OS, but let's try to solve this.

Under normal circumstances due the UAC you have no write access to "..\Program Files\.."

You have updated from 8.80.0300.
HOW did you did this? With the portable archive or with the actual installer?
Since 8.80.0314 the installer prompts you on upgrade to agree
to move the XYplorer data folder to an folder where you have write access, did you agree?

Your current XYplorer.ini should be in that "user\username\AppData\Roaming\xyplorer" folder.
AppData_Roaming_XY_001_c100.png
Location of the appdata-roaming folder on Windows 7
AppData_Roaming_XY_001_c100.png (12.92 KiB) Viewed 1059 times

What is the content of your XY startup.ini?
The size of your ini is 18 byte only, but should be 34 if it would contain the following standard:
[Appdata]
Path=%appdata%\XYplorer


which points to that roaming folder.


Note that this folder may be hidden, as well as the file extensions (as .ini)
To make them visible, press ALT-key and go to "extras > folder options" > "View"
Win7_show-FileTypes_and_Hidden-Folders001_c100.png
How to make hidden visible.
Win7_show-FileTypes_and_Hidden-Folders001_c100.png (28.45 KiB) Viewed 1059 times

----

As an alternative setup, to leave all data-files inside the xyplorer folder,
you can give "Modify" rights for "Users" to the "...\program files\xyplorer\" -folder:
W7_ModifyRights_for_Users_001_c100.png
Right click on XYplorer folder, chose Security and add modify rights to users.
W7_ModifyRights_for_Users_001_c100.png (25.38 KiB) Viewed 1059 times
In that situation you doesn't need the startup.ini at all. Simple rename it to startup.txt.

Shadow
Posts: 33
Joined: 21 Nov 2009 00:00

Re: Error updating ini on exit

Post by Shadow » 04 Apr 2010 20:40

As an alternative setup, to leave all data-files inside the xyplorer folder,
you can give "Modify" rights for "Users" to the "...\program files\xyplorer\"
Setting the permission for the program folder seems to have resolved the issue. Thank you for your rapid response.

I did use the installer, as every time previous, but something must have changed.

Again, thank you.

admin
Site Admin
Posts: 46912
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Error updating ini on exit

Post by admin » 15 Apr 2010 12:25

Shadow wrote:
As an alternative setup, to leave all data-files inside the xyplorer folder,
you can give "Modify" rights for "Users" to the "...\program files\xyplorer\"
Setting the permission for the program folder seems to have resolved the issue. Thank you for your rapid response.

I did use the installer, as every time previous, but something must have changed.

Again, thank you.
Actually on first run after installing the new version XY should have moved your app data files to a writable folder automatically. This seems not to work with some users. I'm still tracking the exact error conditions...

@Stefan: thanks for your great support! :D

j_c_hallgren
XY Blog Master
Posts: 5822
Joined: 02 Jan 2006 19:34
Location: So. Chatham MA/Clearwater FL
Contact:

Re: Error updating ini on exit

Post by j_c_hallgren » 15 Apr 2010 15:10

admin wrote:@Stefan: thanks for your great support! :D
I fully agree with this! He's been much better than I have recently! Keep up the great work! 8)
Still spending WAY TOO much time here! But it's such a pleasure helping XY be a treasure!
(XP on laptop with touchpad and thus NO mouse!) Using latest beta vers when possible.

Post Reply