Page 7 of 11

Re: [β] Everything in XYplorer — Rev. 0.95 / 2014/07/24

Posted: 24 Jul 2014 21:04
by Marco
New release: one bug fixed and fine tuning to squeeze better performance out of the code.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 01:14
by Marco
There's something odd with runret() as pointed out here, http://www.xyplorer.com/xyfc/viewtopic.php?f=2&t=12231, that can affect search results. As a workaround, please set the paramenter $unicode to TRUE.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 06:38
by binocular222
0.9.6 does not work for me. Paper folder is opened with no items. My settings are:

Code: Select all

 $mode = "Smart";				//"Smart"
 $ipc = FALSE;					//FALSE
 $loc_aware = TRUE;				//TRUE
 $diacritics = TRUE;				//TRUE
 $unicode = TRUE;				//FALSE
When I run Everythingexe -svc, this appears in errolog.txt:

Code: Select all

7/25/2014 11:41 AM: Everything 1.3.4.682b (x86): .\src\service_server.c(474): _service_server_main_loop(): bind failed 10048
Is running as service really a must?

Notice that this does works without running ET as a service:

Code: Select all

	$query = input("Everything in XYplorer", "Type your search query as you would in Everything", "D:\ ", "s");
	$list = runret("E:\7Utilities\Search\Everything\es.exe $query");
	paperfolder("Results", "$list");

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 10:13
by Marco
A service is necessary if the account you're using doesn't have admin rights. This link that I provided on the first post, http://forum.voidtools.com/viewtopic.ph ... 72c80c5a9b, explains...everything (no pun intended).
What's your setup?

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 13:13
by binocular222
I got Everything service runs (showed up in services.msc), still not work (Everything runs as admin)

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 13:18
by Marco
But is your account standard user or admin? With what privileges is XYplorer running?

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 13:53
by binocular222
My account is admin, XY runs as admin too

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 25 Jul 2014 14:39
by Marco
I don't know what to say. If you can get es to work then the script should work too. I don't have time nor the possibility to make further tests.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 01:08
by Enternal
I'm also having issues with the new version of the script not working. After modifying this:

Code: Select all

 $query = ($loc_aware XOR ($switches Like "*l*")) ? "$query AND path:""$current_path""" : "$query";
 $query = ($diacritics XOR ($switches Like "*d*")) ? "diacritics:($query)" : "$query";
to:

Code: Select all

 $query = ($loc_aware XOR ($switches Like "*l*")) ? "$query AND path:""$current_path""" : "$query";
 $query = ($diacritics XOR ($switches Like "*d*")) ? "diacritics:$query" : "$query";
So the problem seems to be related to how diacritics is functioning. Basically I stripped away the parentheses. binocular222, try to see if this modification to the code makes it work.

Also Marco, did I just... see Pokemon in your code? :shock: Hahahaha! Not that I'm complaining since even now I'm still watching Pokemon and the movies.

EDIT: Also binoculars222, just to note, they way I have Everything setup is I run Everything as admin, then set it as a service. I then exit Everything and then re-run Everything. Everything will now run as a standard user BUT the service is running as admin and you can see that if you use task manager with elevated rights.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 11:34
by Marco
That's weird. Plus, more importantly, that would be wrong, because

Code: Select all

diacritics:é à
is not the same as

Code: Select all

diacritics:(é à)
I can't repro here.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 18:41
by sinilill
I also can't get the new version to work :(
Had no problems with previos versions!

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 18:48
by Marco
Please try this version. A window will appear: paste the contents here, then XY will execute the script step by step. See if some error message appears.

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 19:42
by sinilill
from dialog window

Code: Select all

dl: diacritics:(groove AND path:\"D:\MUUSIKA\")
script step mode screenshots
http://i.imgur.com/maM5dwV.png

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 20:04
by Marco
Ok, and if you go into

Code: Select all

D:\Application_data\XYplorer\Everything
and then type in the address bar

Code: Select all

!cmd /c es diacritics:(groove AND path:\"D:\MUUSIKA\")
and then press Enter, what appears?

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Posted: 26 Jul 2014 20:30
by sinilill
Nothing, just a command window opens at the location of everything folder.