[β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Discuss and share scripts and script files...
lian00
Posts: 243
Joined: 09 Jul 2014 17:12

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by lian00 » 22 Feb 2018 10:39

yusef88 wrote:does the script work with latest Everything-1.4.1.895 version?
It works for me.
Windows 10 64 bits

randfee
Posts: 43
Joined: 26 Jul 2018 23:07

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by randfee » 30 Jul 2018 03:51

Ziad wrote:I'm getting the following error in XYplorer 18.6 and the latest version of the script (0.96):

Code: Select all

Dubious syntax: #ResolveJunctionsAll
I saw another thread where the author of the script was asking about this specific error and it was supposedly fixed in an earlier version of XYplorer.
same problem, how to solve this?
I don't geht the answer by highend:
highend wrote:Put it in quotes, problem fixed :mrgreen:
the path is in quotes...

Code: Select all

 $path = "C:\Program Files (x86)\Everything\";		//"<xypath>\..\Everything\"
what am I not getting?

jupe
Posts: 1306
Joined: 20 Oct 2017 21:14
Location: 2004 x64

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by jupe » 30 Jul 2018 04:32

he means put #ResolveJunctionsAll in quotes,

e.g "#ResolveJunctionsAll"

From me having a quick look at the script v0.96, it looks like the offending line number is 224:

Code: Select all

 $current_path = ("<curpath>" Like "*paper:*") ? "*" : property("#ResolveJunctionsAll", "<curpath>");

thebib62
Posts: 8
Joined: 10 Oct 2018 10:17

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by thebib62 » 09 Dec 2018 13:17

just wanted to say that the instructions on getting this to work are terrible. Very unclear, and if you do manage to get to work, its a lot of guess work, and in the end it doesn't end up working. I get the above error message. Can someone provide an actual guide on getting this to work?

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 09 Dec 2018 13:34

"The above error message"
Are you talking about "#ResolveJunctionsAll"?

Apart from that, where exactly is the problem and which script exactly did you use?
if you do manage to get to work, its a lot of guess work, and in the end it doesn't end up working
It does work but it doesn't? Em...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Keagel
Posts: 9
Joined: 29 Apr 2020 15:20

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by Keagel » 16 Jul 2020 13:53

Is this script still working for anyone? No matter what I do, the results are always empty for me.

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 16 Jul 2020 14:17

Working fine for me...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Keagel
Posts: 9
Joined: 29 Apr 2020 15:20

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by Keagel » 16 Jul 2020 14:30

Do you have the latest version of Everything? Because I dug into the script and the syntax used doesn't work with my current version of Everything.
Example: diacritics:(query) no longer works, but diacritics:"query" works. The word "AND" is used to separate the query from the path, that doesn't work in Everything anymore either. The quotes in the path are escaped by the script which Everything doesn't like.
All in all, a query like this one:

Code: Select all

diacritics:(everything in xyplorer) AND path:"C:\Users\PC"
is escaped into

Code: Select all

diacritics:(everything in xyplorer) AND path:\"C:\Users\PC\"
but it should be

Code: Select all

diacritics:"everything in xyplorer" path:"C:\Users\PC"
As can be seen:

Image

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 16 Jul 2020 15:15

v1.4.1.963 Beta [Everything]
v1.1.0.10 [es]

I don't update very regularily...

I've never used diacritics at all, sorry. But the script isn't overly complicated so this could easily be fixed...

Do you use the unicode enabled version from here: viewtopic.php?p=109530#p109530
?
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Keagel
Posts: 9
Joined: 29 Apr 2020 15:20

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by Keagel » 16 Jul 2020 15:50

It's fine, I already fixed it. Your Everything version is apparently newer than mine (I'm not using the beta) and your es version is older.
I don't actually use diacritics either, it's just that by default it uses them if you don't disable them in the configuration (this is with the latest version from the first post - 0.96), same thing for the default search path being the current path.
In the version you linked, both loc_aware and diacritics are disabled so that explains why it works for you, because with both of these options disabled your query doesn't get modified.

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 17 Jul 2020 21:14

If anyone is interested, here is my current version. A bit more readable, more security checks, a different way to start Everything and a new feature to store and reuse the last used pattern...

It's only tested with the current versions of es.exe v1.1.0.18 and Everything.exe v1.4.1.969.

Code: Select all

$saveQuery  = TRUE;
Set it to false if you don't want to use the new feature...

Report any bugs...
Attachments
Everything_01.xys
(16.88 KiB) Downloaded 22 times
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

lian00
Posts: 243
Joined: 09 Jul 2014 17:12

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by lian00 » 17 Jul 2020 23:25

Thanks for the update.
Windows 10 64 bits

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 19 Jul 2020 10:05

New version.

UNICODE OPTION REMOVED!

We are living in the 21 century. Everything is or can be unicode. Therefore I've removed that option (unicode is just the default now).

There are two new options:
$extNotes : (ext = extended). If set to TRUE it will show all additional possible "es.exe" switches in the input
dialog for the query. If you already know them by heart you can set it to FALSE, to
disable this behaviour.

$tmpPath : It only makes sense to use this if you have a ram drive where you want to store the
two temporary UTF(8/16) files (written by es.exe). E.g. if your "%TEMP%" paths points
to a SSD and you want to avoid these files being written to it on each run.
Marco, is it ok to split my version into a new thread?
Attachments
Everything_02.xys
(15.7 KiB) Downloaded 27 times
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Marco
Posts: 2304
Joined: 27 Jun 2011 15:20

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by Marco » 19 Jul 2020 15:18

highend wrote:
19 Jul 2020 10:05
Marco, is it ok to split my version into a new thread?
Yeah it's ok, just give some credit for the original idea :roll:
Tag Backup - SimpleUpdater - XYplorer Messenger - The Unofficial XYplorer Archive - Everything in XYplorer
Don sees all [cit. from viewtopic.php?p=124094#p124094]

highend
Posts: 9271
Joined: 06 Feb 2011 00:33

Re: [β] Everything in XYplorer — Rev. 0.96 / 2014/07/24

Post by highend » 19 Jul 2020 15:27

give some credit for the original idea
Thanks and of course!
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Post Reply