Support for Portable Devices

Features wanted...
admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

Filehero wrote:
grindax wrote:However, the other Locked Tree bug from recently is back again.
-----
Guardian of the Locked Tree
Confirmed - and I can add another trigger flavor to it.
It also happens when I insert a CD into the drive, but not upon ejection. Hehe.

FH
Next beta...
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Mesh
Posts: 934
Joined: 24 Mar 2008 21:22

Re: Support for Portable Devices

Post by Mesh »

admin wrote:
1. Yes, it appears that some devices behave like read-only. No error message available. I can repro the same behavior here with Explorer.

Ah, but that limitation doesn't exist in Explorer. I can delete files just fine through Explorer. It's only XY that it doesn't seem to work for.

admin wrote:
2. Hmm, I don't see this here.

Perhaps it's linked to the first problem - something different about how this device has to be handled. For reference, the portable device in question is a Samsung S4 phone.

admin wrote:
3. Cannot be disabled. It's an important warning: PD handling in Windows is not bug free so you should know that you are moving on thinner ice than usual.

I guess for now, that's a fair point. Once everything is running smoothly, and XY is just as reliable as Explorer, I hope there will be a way to disable that.

admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

1. Ah! Gonna check that later...
2. Same.
3. I was not talking about XY bugs, but Windows bugs. It's mentioned in the Help file and I will mention it in the release notes.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Filehero
Posts: 2424
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Support for Portable Devices

Post by Filehero »

admin wrote:Next beta...
Fixed. :)

Shadow
Posts: 33
Joined: 21 Nov 2009 00:00

Re: Support for Portable Devices

Post by Shadow »

Folder View Settings does not apply to Portable Devices?
FolderViewSettings.jpg
FolderViewSettings.jpg (111.42 KiB) Viewed 2311 times

grindax

Re: Support for Portable Devices

Post by grindax »

.
Last edited by grindax on 27 Jan 2016 21:02, edited 1 time in total.

Filehero
Posts: 2424
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Support for Portable Devices

Post by Filehero »

Hi Don,

I've just noticed that a PD doesn't get listed in XY's folder pickers (e.g. User > Manage Commands > Copy To > Location|Browse...).

I don't think you ever wanted this to be added to the manual's This does not work-listing, don't you?


FH

admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

I rather fix it. :)
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Filehero
Posts: 2424
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Support for Portable Devices

Post by Filehero »

admin wrote:I rather fix it. :)
Documentation, a developers biggest nightmare - even controllers, product managers or wifes can't rival.

admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

Yes. Probably also because it's a proof of defeat. The holy grail is a software that does not need documentation. It should be as intuitive as a hammer. I'm still working on it...
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Filehero
Posts: 2424
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Support for Portable Devices

Post by Filehero »

admin wrote:I rather fix it. :)
Fix confirmed. Thanks.

aimy
Posts: 181
Joined: 26 Feb 2007 15:44

Re: Support for Portable Devices

Post by aimy »

Why I am getting when try to access my Samsung Note 3?
2015-03-14_202240_XYplorer.jpg
2015-03-14_202240_XYplorer.jpg (200.74 KiB) Viewed 2160 times
Actually it is showing fine once (I've just upgraded), but then when I try to move the files from my phone and paste to my local drive, it is saying something "requested resource was in used", the same error that I've been getting before this when try to paste external device files (open from native Windows Explorer).

Please help.

Thank you.

admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

Hm, looks like there is something totally incompatible. Clueless.

I have seen that error here as well (but not recently). Some devices behave as read-only. See if you can copy the files instead of move.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

aimy
Posts: 181
Joined: 26 Feb 2007 15:44

Re: Support for Portable Devices

Post by aimy »

admin wrote:Hm, looks like there is something totally incompatible. Clueless.

I have seen that error here as well (but not recently). Some devices behave as read-only. See if you can copy the files instead of move.
Well, surprisingly after I taking the screenshot, when I return back, it is showing normally again with The Phone & Card list.

But the issue of resource is being used persists for both move and copy operation. Any possible fix?

It really cumbersome to use native Windows Epxlorer for this since I have already set several favourite folders inside XYplorer.

Thank you..

admin
Site Admin
Posts: 51627
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Support for Portable Devices

Post by admin »

It's on my list.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Post Reply