XYplorer.ini being saved as UTF-16?

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
fizzybiz
Posts: 18
Joined: 18 Jul 2020 10:05

XYplorer.ini being saved as UTF-16?

Post by fizzybiz »

I realise this is unusual, but I've added my XYplorer.ini file to a Git repo - mainly to try "syncing" settings between various machines.

What I'm seeing is that Git can't properly diff the XYplorer.ini file because it recognises it as "Little-endian UTF-16"

This is the output of the Git command "file *" ("file" is a windows-specific Git function):

Code: Select all

XYplorer.ini:   Little-endian UTF-16 Unicode text, with very long lines, with CRLF, CR line terminators
Since Git doesn't recognise UTF-16 as "text", it just shows "binary files differ" without showing what has changed in the ini file.

So I'm wondering if there is a way to get XYplorer to save the ini file as UTF-8?

Cheers!

elqasar2
Posts: 118
Joined: 27 Oct 2017 14:04

Re: XYplorer.ini being saved as UTF-16?

Post by elqasar2 »

Notepad++ sees it as 'UCS-2 LE BOM' (which is a precursor to UTF-16 from what I've found online). How unusual. :eh:

yuyu
Posts: 84
Joined: 19 Jun 2018 12:40

Re: XYplorer.ini being saved as UTF-16?

Post by yuyu »

Notepad3 sees it as Unicode UTF16(BOM)

yuyu
Posts: 84
Joined: 19 Jun 2018 12:40

Re: XYplorer.ini being saved as UTF-16?

Post by yuyu »

Hm)) What if resave it as UTF8? Will it be read?

yuyu
Posts: 84
Joined: 19 Jun 2018 12:40

Re: XYplorer.ini being saved as UTF-16?

Post by yuyu »

yes. it's been read and stays UTF8.

admin
Site Admin
Posts: 50050
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer.ini being saved as UTF-16?

Post by admin »

The format is "UTF-16LE with Signature" with CRLF line endings, that's a standard Unicode text format. Who could have problems with it? :?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Post Reply