Page 1 of 1

PDF Preview Suddenly Lost

Posted: 12 Jun 2020 13:53
by kevin
Hi All,
I've searched and read posts about losing the PDF preview feature, mine disappeared suddenly without any updates happening. I use PDF X-Change Editor full version 8, uninstalled Adobe Reader (don't need it) and tried everything on the FAQ "XYplorer does not preview PDFs. What can I do about that?" but still no preview. I also installed PDF X-Change Viewer 2.5 (the final version they say) but that didn't do it.

FAQ says the X-Change Editor version 8 is not recommended, but I have Viewer installed and still no go.

I entered the User-Defined Preview Handler twice, no luck, then deleted it and still no change.
I can preview MS Office and image files as usual, only the PDFs are affected.

I got to depend on this feature at work, was so handy I could change a file name while looking at the PDF itself. Any advice is much appreciated! I don't need Adobe Reader nor the Viewer, just the main X-Change Editor program is necessary.

Best Regards, Kevin

Re: PDF Preview Suddenly Lost

Posted: 16 Jun 2020 10:41
by kevin
Any takers on this one??? I'm the only one that this has happened to ???
Thanks Kevin

Re: PDF Preview Suddenly Lost

Posted: 16 Jun 2020 10:46
by highend
Show a screenshot of shellexview (the 64-bit version) (

- Sorted by "Type"
- With the column "CLSID" (move it to the left like I did it in my screenshot)!
- Only showing the entries with "Preview Handler" (as type) and with this setting enabled:

Menu - Options - [x] Show 32-bit Shell Extensions

Like so:
2020-06-16_104637.png (35.58 KiB) Viewed 233 times

Re: PDF Preview Suddenly Lost

Posted: 18 Jun 2020 15:32
by kevin
Hello Highend,
Thanks for your reply you always come through for us!

Funny just before I saw your reply I solved it by chance -- just uninstalled my PDF Xchange Editor software and reinstalled it -- preview in XYplorer works perfectly now.

I might have lied in my first post, I think around the time of losing preview I installed a trial of another PDF software, not sure of the timing but this might have whacked-out my Xchange Editor. So I uninstalled the other software first, but the preview was still missing, so uninstalled - reinstalled the primary PDF and all is good now.

Really became dependent on the preview floating panel, I can read a manual's title while I re-name it's file and it doesn't even make a hiccup!

Thanks for coming back to me on this one!
Best Regards, Kevin