Page 1 of 1

Cinema4D - Drag and drop support?

Posted: 17 May 2019 16:34
by michaelwalz
Hi guys. I love Xyplorer and use it daily. Another program I love and use daily is Cinema 4D.

The only problem is that drag and drop does not work from Xyplorer to C4D. When I drag an image or something from XY onto C4D, the little plus appears under the cursor but nothing happens when I release the mouse button.

Is there something unique about how C4D handles drag and drop that causes this?
Could XY be updated to enable this to work?

Currently as a workaround, I just have a button to open Windows Explorer and select the current file. Then I can drag onto C4D without issue. But I'd love it if it worked natively.

Thanks!

Re: Cinema4D - Drag and drop support?

Posted: 17 May 2019 19:25
by MaxEnrik
Cinema 4D isn't the only one, also XY doesn't support drag and drop for ST3. (Maybe we missing something to set for run them?! Don't know, yet.)

Re: Cinema4D - Drag and drop support?

Posted: 17 May 2019 19:46
by highend
XY doesn't support drag and drop for ST3
It does, but not to the x64 version of it...

Re: Cinema4D - Drag and drop support?

Posted: 17 May 2019 20:12
by MaxEnrik
It does, but not to the x64 version of it...
So looks like reason is x64?
Maybe that is why XY only viewing few of .c4d file thumbnails in my machine?

Re: Cinema4D - Drag and drop support?

Posted: 20 May 2019 22:56
by michaelwalz
MaxEnrik wrote:
17 May 2019 20:12
It does, but not to the x64 version of it...
So looks like reason is x64?
Maybe that is why XY only viewing few of .c4d file thumbnails in my machine?
Looks like you've hit on it. Because it does seem that it is a 32-bit (XYPlorer) to 64-bit (Cinema4D) issue.

I don't know if this is correct, but there are lots of other people who have experienced it, and it seems to be related to a Windows bug on the drop functionality: https://stackoverflow.com/questions/396 ... -to-64-bit

Re: Cinema4D - Drag and drop support?

Posted: 06 Jun 2019 11:10
by admin
Yes. Everybody is praying for a fix.

Re: Cinema4D - Drag and drop support?

Posted: 06 Jun 2019 19:35
by michaelwalz
admin wrote:
06 Jun 2019 11:10
Yes. Everybody is praying for a fix.
Thanks Donald!
Keep up the great work :)
MaxEnrik wrote:
17 May 2019 20:12
So looks like reason is x64?
Maybe that is why XY only viewing few of .c4d file thumbnails in my machine?
Well, I think I figured out the Windows .c4d thumbnails. Or at least I can reproduce the behavior.
First of all, my Explorer previews for C4D files wasn't working, so I followed this tutorial to get the Preview Handler working again: https://www.youtube.com/watch?v=ZKXTMCXQuhw

After that, I could preview files in Windows Explorer no problem. Then I found the Cinema4D file preview handler in the registry. Then in XY I added the following text under Tools > Configuration > Preview > Previewed Formats > User-Defined Preview Handlers.

c4d>{2BAA7283-B8CA-4993-91F7-CE75B780E1F0}

Image

After doing this, only a few would preview in XY. I couldn't figure it out, but then I tried viewing a few more file previews in Windows and when I came back to XY it suddenly could display those file previews! It had a bit of text on the right side of the preview tab that said "Preview created by the shell. Size: 500 x 347, zoomed to 710 x 493, File size: xxxxxx, loaded in 42 ms".

That gave me a clue that maybe whatever XYplorer needed to display the previews was only generated after displaying the previews in the Windows Explorer preview pane. Sure enough, after popping out to Windows explorer, previewing, and then coming back to XYplorer worked perfectly and it could display inside XY.

I don't suppose there is a way to automate this, or force the Windows shell to generate the preview when XY tries to display it?

Just dreaming of course. I just like spending as little time in Windows Explorer as possible :lol:

Re: Cinema4D - Drag and drop support?

Posted: 06 Jun 2019 20:11
by admin
So XY is feeding on the Explorer cache? File scavenger! (No, there is no way to automate this short of evil hacks.)

Re: Cinema4D - Drag and drop support?

Posted: 07 Jun 2019 08:06
by jupe
@michaelwalz: Not sure if you searched the forum, but you might have found this: viewtopic.php?f=3&t=20385#p169823

Re: Cinema4D - Drag and drop support?

Posted: 07 Jun 2019 19:01
by michaelwalz
jupe wrote:
07 Jun 2019 08:06
@michaelwalz: Not sure if you searched the forum, but you might have found this: viewtopic.php?f=3&t=20385#p169823
Thank you so much @jupe!
I had searched back when I originally made the post, and didn't find much. But with your help in MaxEnrik's post you linked, I was able to get it fully working!

The trick was finding the 32-bit C4D preview handler .dll, but after I found and registered that file it's working 100%!

If anyone comes across this later who wants to install the C4D 32-bit preview handler for XYPlorer, here is the file you would need: http://www.yourfilelink.com/get.php?fid=2039091