images in the clipboard and ctrl-Hover

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
glusberg
Posts: 35
Joined: 04 Dec 2010 17:47

images in the clipboard and ctrl-Hover

Post by glusberg » 29 Mar 2019 17:52

I can't see images when trying to, while hovering over the clipboard on the toolbar, or through ctrl-hover on the different toolbar buttons. I am guessing it must be a setting on my system. Any hints on where to look? (running 19.80.0128)

admin
Site Admin
Posts: 47703
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: images in the clipboard and ctrl-Hover

Post by admin » 29 Mar 2019 20:06

Are you sure that there is an image in the clipboard?

glusberg
Posts: 35
Joined: 04 Dec 2010 17:47

Re: images in the clipboard and ctrl-Hover

Post by glusberg » 29 Mar 2019 21:50

I was, and it did. But your question drove me to think about other programs interfering. For many years I have used Ditto (https://sourceforge.net/projects/ditto-cp/), and when I closed it, then it all worked as you promised it would. Too bad. Its the first time XY gets tangled up like this...
I like what you did with/for the clipboard, but I depend on Ditto almost as much as I do on XY. I'll do without the new functionality.

Thanks for your help.

admin
Site Admin
Posts: 47703
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: images in the clipboard and ctrl-Hover

Post by admin » 29 Mar 2019 22:01

So that ditto locks the clipboard? You also don't see any textual clipboard contents when you hover that button?

glusberg
Posts: 35
Joined: 04 Dec 2010 17:47

Re: images in the clipboard and ctrl-Hover

Post by glusberg » 30 Mar 2019 00:31

No, it does not block the button (functionality). I am not totally sure what locking the clipboard means.
In fact, the hovering tells me there is an image in the clipboard, and the filename (in my test, a jpg). Confusing.

SammaySarkar
Posts: 4205
Joined: 12 Mar 2014 17:27
Location: Asteroid B-612 / Dhaka
Contact:

Re: images in the clipboard and ctrl-Hover

Post by SammaySarkar » 30 Mar 2019 06:26

I'm also using ditto, and I don't see any such conflict.
glusberg wrote:
30 Mar 2019 00:31
In fact, the hovering tells me there is an image in the clipboard, and the filename (in my test, a jpg). Confusing.
This makes me think you're copying an image file to clipboard. In this case, the clipboard doesn't infact hold any image data, hence the button preview shows nothing.
Here's an experiment: press the PrintScreen key (or do File > to Clipboard > Image with an image file selected in XY), then check if the toolbar button shows an image.

glusberg
Posts: 35
Joined: 04 Dec 2010 17:47

Re: images in the clipboard and ctrl-Hover

Post by glusberg » 30 Mar 2019 15:15

Bingo! Sammaysarkar is totally correct. I am an idiot.
I was close; it wasn't a problem in my system, it was me.
Apologies!

Post Reply