what happened to my rating stars?

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
JLoftus
Posts: 242
Joined: 22 Jan 2014 14:58

what happened to my rating stars?

Post by JLoftus » 22 Nov 2018 16:34

SSIA... any idea what happened here? My "rating stars" got replaced with a square character:
RatingStars.png
RatingStars.png (8.01 KiB) Viewed 679 times

highend
Posts: 8206
Joined: 06 Feb 2011 00:33

Re: what happened to my rating stars?

Post by highend » 22 Nov 2018 16:40

And the current font is?
One of my scripts helped you out? Please donate via Paypal or highend (at) web (dot) de

JLoftus
Posts: 242
Joined: 22 Jan 2014 14:58

Re: what happened to my rating stars?

Post by JLoftus » 22 Nov 2018 16:46

Currently SegoeUI. I just tried changing it to a few others, Arial, Consolas, Courier New, all show the same squares. Any other thoughts?
fonts.png
fonts.png (12.77 KiB) Viewed 673 times

highend
Posts: 8206
Joined: 06 Feb 2011 00:33

Re: what happened to my rating stars?

Post by highend » 22 Nov 2018 16:59

Mh, no. Works fine here on 19.40 with your font settings...
One of my scripts helped you out? Please donate via Paypal or highend (at) web (dot) de

JLoftus
Posts: 242
Joined: 22 Jan 2014 14:58

Re: what happened to my rating stars?

Post by JLoftus » 22 Nov 2018 17:01

Dang. thanks. I'm running 19.40 also. No idea when or what changed. Maybe Don has some idea what I might try. thanks again

jupe
Posts: 1157
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: what happened to my rating stars?

Post by jupe » 22 Nov 2018 20:09

This is because of the 1809 Windows update, it is not the fault of XY. As a workaround I started using this font for Main Contents "Microsoft YaHei UI", it it pretty similar to Segoe UI but not as good, also the context menus still display blank rectangles obviously.

If someone could upload the Sergoe UI from 1803, I would like to try installing it over the 1809 version to see if it fixes it OS wide.

Leito
Posts: 533
Joined: 26 Sep 2016 15:37
Location: Windows 10 1809 x64

Re: what happened to my rating stars?

Post by Leito » 22 Nov 2018 20:14

jupe wrote:
22 Nov 2018 20:09
If someone could upload the Sergoe UI from 1803, I would like to try installing it over the 1809 version to see if it fixes it OS wide.
There you go.
Attachments
Segoe UI - Win10 1803 17134.407.7z
(2.72 MiB) Downloaded 10 times

jupe
Posts: 1157
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: what happened to my rating stars?

Post by jupe » 22 Nov 2018 20:47

Thanks Leito! :) , I will let you know how it goes.

MS seriously messed with the fonts in 1809, I have been hoping they might possibly fix it in subsequent updates, but nothing so far because they have only just re-released the OS update. Many chars won't display in message boxes and Windows menus that worked fine in 1803.

JLoftus
Posts: 242
Joined: 22 Jan 2014 14:58

Re: what happened to my rating stars?

Post by JLoftus » 22 Nov 2018 21:58

Dang. You are exactly correct, but alas, it's not just Segoe UI, it's almost every system font! I just forced the 1809 update and now I am regretting that, this is awful.

I just went through and tried dozens of them, and all of them result in the square character except for a few non-MS fonts. I settled on this one, but I am really not loving it:
fonts2.png
fonts2.png (67.57 KiB) Viewed 640 times

Nighted
Posts: 435
Joined: 21 Jan 2007 01:58
Location: Gitmo Nation North, Win 7/10/Linux/(x64)

Re: what happened to my rating stars?

Post by Nighted » 22 Nov 2018 22:53

If it ain't broken, fix it 'til it is! :biggrin:
I want XY to serve soft ice cream. Please Don, make XY serve soft ice cream.

highend
Posts: 8206
Joined: 06 Feb 2011 00:33

Re: what happened to my rating stars?

Post by highend » 23 Nov 2018 00:27

Or more accurately: If you don't have a broken system yet, just install Windows 10. Mission accomplished...
One of my scripts helped you out? Please donate via Paypal or highend (at) web (dot) de

JLoftus
Posts: 242
Joined: 22 Jan 2014 14:58

Re: what happened to my rating stars?

Post by JLoftus » 23 Nov 2018 00:57

https://answers.microsoft.com/en-us/win ... 85c28df51e
and
https://borncity.com/win/2018/10/25/win ... lback-bug/

Edit: And... we have a fix... sort of.

Set the font to Segoe UI Symbol and the stars are back.
fonts3.png
fonts3.png (62.9 KiB) Viewed 621 times

jupe
Posts: 1157
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: what happened to my rating stars?

Post by jupe » 23 Nov 2018 01:41

FYI I tried the 1803 Segoe UI, no joy, which seems to confirm it is the fallback mechanism in 1809 not the actual font, so AFAICT we'll have to wait for possible OS update to fix menus and message boxes etc.

jupe
Posts: 1157
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: what happened to my rating stars?

Post by jupe » 31 Jan 2019 15:15

Amazingly I just noticed my rating stars have returned! (even in menus)

I recently updated to 10.0.17763.292 so I assume it must have just gotten fixed in that update or the previous one, I am very surprised, I thought MS would drag their feet for longer fixing this, anyway I just thought I'd let anyone that may have been using a sub optimal font as an interim measure, that it seems its back to normal again.

admin
Site Admin
Posts: 47164
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: what happened to my rating stars?

Post by admin » 10 Feb 2019 16:00

Wow, how weird. So the problem came up and disappeared again? Good, otherwise I would have had to make the star configurable, assuming it is at some position in any font. But really, this should not be font-dependent. Unicode characters should be stable across fonts. Another proof that MS are slowly going nuts...

Post Reply