win+e launching without any 3rd party solution

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
univert
Posts: 28
Joined: 14 Aug 2010 10:03

win+e launching without any 3rd party solution

Post by univert »

copy the following content to a .bat file and move the .bat file into the root folder of xyplorer; run it and it works

Code: Select all

reg copy HKEY_CLASSES_ROOT\folder\shell\opennewwindow\command HKEY_CLASSES_ROOT\folder\shell\opennewwindow\command.bak /f
reg delete HKEY_CLASSES_ROOT\folder\shell\opennewwindow\command /v DelegateExecute /f
reg add HKEY_CLASSES_ROOT\folder\shell\opennewwindow\command /ve /d "%~dp0XYplorer.exe" /f
I think this can be in integrated into xyplorer itself.

Bart
Posts: 96
Joined: 05 Feb 2017 14:29

Re: win+e launching without any 3rd party solution

Post by Bart »

It does not work.

highend
Posts: 9555
Joined: 06 Feb 2011 00:33

Re: win+e launching without any 3rd party solution

Post by highend »

Execute this line from a command prompt and post a screenshot of the output...

REG QUERY HKEY_CLASSES_ROOT\folder\shell\opennewwindow\command
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Bart
Posts: 96
Joined: 05 Feb 2017 14:29

Re: win+e launching without any 3rd party solution

Post by Bart »

Here it is:
Attachments
2020-01-09 18_20_54-Command Prompt.jpg
2020-01-09 18_20_54-Command Prompt.jpg (21.02 KiB) Viewed 672 times

highend
Posts: 9555
Joined: 06 Feb 2011 00:33

Re: win+e launching without any 3rd party solution

Post by highend »

So obviously you've never executed the lines posted by univert,
or executed them without admin permissions and got ERROR: Access is denied. error messages...

and before you execute them (with proper permissions), don't forget to do it from inside XYplorers root folder
otherwise the XYplorer.exe entry will have the wrong path...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Bart
Posts: 96
Joined: 05 Feb 2017 14:29

Re: win+e launching without any 3rd party solution

Post by Bart »

Then tell me what to do after viewing my attachment.
Attachments
2020-01-09 18_42_52-Startup.bat - Notepad.jpg
2020-01-09 18_42_52-Startup.bat - Notepad.jpg (129.25 KiB) Viewed 667 times

highend
Posts: 9555
Joined: 06 Feb 2011 00:33

Re: win+e launching without any 3rd party solution

Post by highend »

Execute it with admin permissions? oO
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Bart
Posts: 96
Joined: 05 Feb 2017 14:29

Re: win+e launching without any 3rd party solution

Post by Bart »

I have full access and full control both as admin (default) as well as User.

highend
Posts: 9555
Joined: 06 Feb 2011 00:33

Re: win+e launching without any 3rd party solution

Post by highend »

Great! The problem is, that the OS doesn't care about you thinking that you have full admin permissions only because your user account belongs to the administrators group...

So can you finally right click that .bat file and use "Run as administrator" from the context menu, please?
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Bart
Posts: 96
Joined: 05 Feb 2017 14:29

Re: win+e launching without any 3rd party solution

Post by Bart »

Yes, this indeed works, the programs starts using the key combination. I need advice if this is a permanent solution or does the file have to be run again after windows startup. Thanks.

highend
Posts: 9555
Joined: 06 Feb 2011 00:33

Re: win+e launching without any 3rd party solution

Post by highend »

It's a registry entry^^ As long as you don't overwrite it, it's permanent...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Post Reply