New Tab and Tab List icons are gone

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
SrAlloza
Posts: 7
Joined: 10 May 2018 23:29

New Tab and Tab List icons are gone

Post by SrAlloza » 10 May 2018 23:35

As the subject says, i can't see neither the new tab icon nor the tab list icon.
I'm running XYplorer 18.90.0100, on windows 10 x64

NOTE: in the picture the cursor is not shown, but actually it's on the New Tab button.
NOTE2: I have the tab list button active, but as the new tab icon it's not visible.
Attachments
1.png
1.png (138.3 KiB) Viewed 981 times

serendipity
Posts: 3348
Joined: 07 May 2007 18:14
Location: NJ/NY

Re: New Tab and Tab List icons are gone

Post by serendipity » 11 May 2018 00:06

Welcome!
Maybe you turned it off by mistake?
Enable from Tools>Configuration>Tabs and Panes>Tabs Show 'New Tab' button and Show 'Tab List' button

SrAlloza
Posts: 7
Joined: 10 May 2018 23:29

Re: New Tab and Tab List icons are gone

Post by SrAlloza » 11 May 2018 00:16

serendipity wrote:Welcome!
Maybe you turned it off by mistake?
Enable from Tools>Configuration>Tabs and Panes>Tabs Show 'New Tab' button and Show 'Tab List' button
Thanks for the quick answer, but unfortunately I have them actived. In the image you can notice that in the second panel, near the position where the "new tab" icon shoud be, there's a label saying "New tab". To explain it better: I can click the button, and it works just fine. The problem is that the icon is not shown, but the button it's still useful, so the problem is only the icon.

jupe
Posts: 1240
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: New Tab and Tab List icons are gone

Post by jupe » 11 May 2018 00:32

This may sound silly, but you could try upgrading to latest beta via the help menu and see if it fixes itself because I have never heard of or seen this happen before, did you download XY from the website or a 3rd party?

Hold Ctrl down and click this: Help | Online Support | Check for Updates

serendipity
Posts: 3348
Joined: 07 May 2007 18:14
Location: NJ/NY

Re: New Tab and Tab List icons are gone

Post by serendipity » 11 May 2018 00:35

Ok, so this happened suddenly or happened one first use?

Try, file > restart without saving? is you haven't saved the settings yet.

SrAlloza
Posts: 7
Joined: 10 May 2018 23:29

Re: New Tab and Tab List icons are gone

Post by SrAlloza » 11 May 2018 11:28

jupe wrote:This may sound silly, but you could try upgrading to latest beta via the help menu and see if it fixes itself because I have never heard of or seen this happen before, did you download XY from the website or a 3rd party?

Hold Ctrl down and click this: Help | Online Support | Check for Updates
I downloaded it from the XY website, and it's updated. For checking, I have uninstalled XY and downloaded it from the website again, but the issue is still there.
serendipity wrote:Ok, so this happened suddenly or happened one first use?

Try, file > restart without saving? is you haven't saved the settings yet.
I have tried your solution, but I still can't see the icons. I expected it, because the issue started one week ago, suddenly. I have searched for solutions for it, but apparently no one has it.

jupe
Posts: 1240
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: New Tab and Tab List icons are gone

Post by jupe » 11 May 2018 11:40

This isn't meant as a solution, but you could try toggling this setting

Configuration | Tabs and Panes | Tabs | Visual style

SrAlloza
Posts: 7
Joined: 10 May 2018 23:29

Re: New Tab and Tab List icons are gone

Post by SrAlloza » 11 May 2018 12:25

jupe wrote:This isn't meant as a solution, but you could try toggling this setting

Configuration | Tabs and Panes | Tabs | Visual style
I changed the visual style to XYplorer Classic Style, and some some icons were shown (although those icons were not the real icons). Considering the lack of forum entries of this problem and the last test, I think this problem has nothing to do with XYplorer.
classic-xy-theme.png
classic-xy-theme.png (119.63 KiB) Viewed 935 times
Thanks to your idea, I think I'm closer to the source of the issue:
I have a 4k window on my pc. The problem is that many apps doesn't adjust their interfaces to 4k, so I need to manually kind of force adaptation, by creating a shortcut on the desktop and: properties > Compatibility > Override high DPI scaling behavior, and then I try with Application, System and System (Enhanced), and Ieave the one that seems to be the best. With XYplorer, trying Application is the same as do nothing. Trying System and System (Enhanced) produces the same result: both icon are shown (new tab and tab list icons), but the interface is destroyed, as you can see in the picture.
interface_destroyed.png
interface_destroyed.png (269.41 KiB) Viewed 935 times
I know that the issue is outside the domain of XYplorer, but I truly appreciate your ideas.

jupe
Posts: 1240
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: New Tab and Tab List icons are gone

Post by jupe » 11 May 2018 12:45

I have never used/seen a 4k screen so I doubt I will be much help, but you could try my suggestion here:

viewtopic.php?t=18229#p155952

edit: Also without even using the above suggestion but still turning DPI shortcut properties scaling off, you can control the toolbar size with Ctrl+Shift+Mouse Wheel over toolbar and font size with Ctrl+MouseWheel in the list for fine tuning of sizing (if you haven't disabled that feature in config), also Ctrl+Shift+MouseWheel in list will adjust line spacing.

SrAlloza
Posts: 7
Joined: 10 May 2018 23:29

Re: New Tab and Tab List icons are gone

Post by SrAlloza » 11 May 2018 13:12

jupe wrote:I have never used/seen a 4k screen so I doubt I will be much help, but you could try my suggestion here:

viewtopic.php?t=18229#p155952

edit: Also without even using the above suggestion but still turning DPI shortcut properties scaling off, you can control the toolbar size with Ctrl+Shift+Mouse Wheel over toolbar and font size with Ctrl+MouseWheel in the list for fine tuning of sizing (if you haven't disabled that feature in config), also Ctrl+Shift+MouseWheel in list will adjust line spacing.
Thanks Jupe!
I didn't try your idea exactly as you said, but I managed to get to a solution.

I activated the override dpi option, and then with Ctrl + Shift + MouseWheel and Ctrl + MouseWheel I adjusted the interface as I had before, so problem solved.

jupe
Posts: 1240
Joined: 20 Oct 2017 21:14
Location: 1903 x64

Re: New Tab and Tab List icons are gone

Post by jupe » 11 May 2018 13:21

Good news.

PS: You may not find this useful info but FYI if you want to protect information for posting screenshots you can enter

Code: Select all

obfuscate;
in the XY address bar, take a screenshot and then select it from the drop down list when you want to switch it off again, or make a toolbar button for it etc, also if you are using the PrntScr button which it looks like you might be Alt+PrintScreen takes the capture without including the taskbar.

RalphM
Posts: 1256
Joined: 27 Jan 2005 23:38
Location: Cairns, Australia

Re: New Tab and Tab List icons are gone

Post by RalphM » 12 May 2018 13:58

And another FYI:
To create partial screenshots use a tool like PicPick or similar so you don't have to obfuscate all the stuff you're not talking about anyway...
Ralph :-)
(OS: W10 1809 Home x64 - XY: Current beta)

Post Reply