I cannot see my mapped samba shares on the left navigation

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
Post Reply
mrjayviper
Posts: 4
Joined: 30 Mar 2016 16:04

I cannot see my mapped samba shares on the left navigation

Post by mrjayviper » 30 Mar 2016 16:10

On Directory Opus, Windows Explorer and Explorer++, the left navigation tree includes my mapped samba shares. Using XYplorer, I cannot see them. I looked at the settings and "Show Network Folder" is enabled. I cannot find any other setting that would prevent this.

Any ideas on how to make my mapped Samba shares appear on the left navigation tree? thanks a lot

sinilill
Posts: 111
Joined: 02 Dec 2013 18:37

Re: I cannot see my mapped samba shares on the left navigati

Post by sinilill » 30 Mar 2016 22:47

What Windows are you using?
Are you sure your drives are mapped?

mrjayviper
Posts: 4
Joined: 30 Mar 2016 16:04

Re: I cannot see my mapped samba shares on the left navigati

Post by mrjayviper » 31 Mar 2016 04:58

seems XYplorer has problem listing mapped drives if it's run as admin. It's working fine now. Thanks :)

TheQwerty
Posts: 4353
Joined: 03 Aug 2007 22:30

Re: I cannot see my mapped samba shares on the left navigati

Post by TheQwerty » 31 Mar 2016 12:52

Welcome to the club, mrjayviper!

You might find this useful: https://technet.microsoft.com/en-us/lib ... s.10).aspx
When network shares are mapped, they are linked to the current logon session for the current process access token. This means that if a user uses the command prompt (cmd.exe) together with the filtered access token to map a network share, the network share is not mapped for processes that run with the full administrator access token.

Resolution

To work around this problem, configure the EnableLinkedConnections registry value. This value enables Windows Vista and Windows 7 to share network connections between the filtered access token and the full administrator access token for a member of the Administrators group. After you configure this registry value, LSA checks whether there is another access token that is associated with the current user session if a network resource is mapped to an access token. If LSA determines that there is a linked access token, it adds the network share to the linked location.

To configure the EnableLinkedConnections registry value
  1. Click Start, type regedit in the Start programs and files box, and then press ENTER.
  2. Locate and then right-click the registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
  3. Point to New, and then click DWORD Value.
  4. Type EnableLinkedConnections, and then press ENTER.
  5. Right-click EnableLinkedConnections, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor, and then restart the computer.

highend
Posts: 8476
Joined: 06 Feb 2011 00:33

Re: I cannot see my mapped samba shares on the left navigati

Post by highend » 31 Mar 2016 16:27

Just to make this clear: It's not an issue with XYplorer!

The code that could be pasted into a command prompt (with admin permissions):

Code: Select all

REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" /v "EnableLinkedConnections" /t REG_DWORD /d "0x00000001" /f
One of my scripts helped you out? Please donate via Paypal or highend (at) web (dot) de

Post Reply