XYplorer slow to open

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

My thought in wondering if there was any similarity between xyplorer and what was happening with Vuze is looking at it from a computer's standpoint, so to speak, what goes on in the loading process, especially early on; i.e., if there is a potential bottleneck here, where might it be?

aimy
Posts: 181
Joined: 26 Feb 2007 15:44

Re: XYplorer slow to open

Post by aimy »

Follow...

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

aimy wrote:Follow...
Hä?

Whatever, there is no bottleneck. When we are talking about 30 seconds I can only think of this:
- network
- virus
- anti-virus
- bad cluster
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

admin wrote:
aimy wrote:Follow...
Hä?

Whatever, there is no bottleneck. When we are talking about 30 seconds I can only think of this:
- network
- virus
- anti-virus
- bad cluster
Since afaict this is an xyplorer-only behavior, and I take great ongoing care about malware, and drives have been checked for bad clusters - only something involved with Comodo seems a plausible alternative explanation from your list. I will investigate.

Follow up: Right after posting this, I opened xyplorer from its icon on the task bar and it took 1.3 secs. Puzzled, as I didn't think I had started it before that, I rebooted and the next time was 1.1 secs. Since I normally open xyplorer from folder-specific icons on my desktop, e.g., C:\, C:\Program Files, E:\Music, etc., I rebooted a few times trying some of those. They've been taking 6-11 secs. I also noticed that my computer is starting 10 secs faster today. Who knows? Maybe the new SSD needed a day or two to hit stride... I'll follow up if I learn anything more.

kunkel321
Posts: 590
Joined: 10 Jun 2012 03:45
Location: Near Seattle

Re: XYplorer slow to open

Post by kunkel321 »

Just got into my office and booted up, and every blasted thing is slow.. Probably because my workplace is pushing updates, IDK. Anyway, it's always interesting to see what parts of the XY startup is impacted by this...

========
XY ver: XYplorer 15.20.0204
OS: Windows 7 Enterprise (Service Pack 1), 32-bit
Loaded: 2015-05-29 14:06:01 in 50,257 ms

0 ms: 1,729 ms - Start Load
1,729 ms: 37 ms - Init Language
1,766 ms: 121 ms - Load Language
1,887 ms: 1,208 ms - Load Settings
3,095 ms: 44 ms - Init Custom File Icons
3,139 ms: 93 ms - Init Controls
3,232 ms: 262 ms - Init Graphics
3,494 ms: 22 ms - Init Tabs
3,516 ms: 59 ms - Create Info Panel
3,575 ms: 133 ms - Set Interface Font
3,708 ms: 184 ms - Init Panes
3,892 ms: 472 ms - Init Tree
4,364 ms: 7 ms - Tab Icons
4,371 ms: 17 ms - Load Catalog
4,388 ms: 31 ms - Load Tags
4,419 ms: 9,864 ms - Load Tree
14,283 ms: 295 ms - Init Custom Toolbar Buttons
14,578 ms: 126 ms - Init UDC and KS
14,704 ms: 1,796 ms - Load This Pane
16,500 ms: 28,489 ms - Load Other Pane
44,989 ms: 977 ms - Layout Window
45,966 ms: 840 ms - Show Window
46,806 ms: 3,451 ms - Init Menus
50,257 ms: - Load Done

MaxiTree: Rows=115, Nodes=115, Expanded=7, Mapped Drives=5, Portable Devices=1
Check Existence of Subfolders in Tree: Yes
Pane 1: Items=5/66, Pane 2: Items=34/34, Catalog: Items=11
============

Note sure if relevant: Pane 1 had all 66 items visible. Pane 2 was closed...
ste(phen|ve) kunkel

Stef123

Re: XYplorer slow to open

Post by Stef123 »

I also have to report slower startup than with earlier versions. Not consistently, though. Shrugged it off at first, but it keeps recurring. It varies a lot depending on what ini I start up. Nothing else has changed, except for switching the Windows locale. Seems like XY also suffers from jet lag. :titter: It's not excrutiatingly slow, but noticably slower than it used to be.

SammaySarkar
Posts: 4235
Joined: 12 Mar 2014 17:27
Location: Asteroid B-612 / Dhaka
Contact:

Re: XYplorer slow to open

Post by SammaySarkar »

kunkel321 wrote:Just got into my office and booted up, and every blasted thing is slow.. Probably because my workplace is pushing updates, IDK. Anyway, it's always interesting to see what parts of the XY startup is impacted by this...

Code: Select all

 1,887 ms:   1,208 ms - Load Settings
 3,095 ms:      44 ms - Init Custom File Icons
...
 4,419 ms:   9,864 ms - Load Tree
14,283 ms:     295 ms - Init Custom Toolbar Buttons
loading icons is causing big slowdowns. Maybe harddrive access is hampered because of those on-going updates.

Code: Select all

16,500 ms: 28,489 ms - Load Other Pane
44,989 ms: 977 ms - Layout Window
Window layout is always [relatively] slow, but it's usually in the ms range. Maybe here again loading all those many different icons for list files/catalogs is causing a ^similar^ but bigger slowdown.
Note sure if relevant: Pane 1 had all 66 items visible. Pane 2 was closed...
No, no pane is ever closed, they can only be hidden.
Icon Names | Onyx | Undocumented Commands | xypcre
[ this user is asleep ]

SammaySarkar
Posts: 4235
Joined: 12 Mar 2014 17:27
Location: Asteroid B-612 / Dhaka
Contact:

Re: XYplorer slow to open

Post by SammaySarkar »

by the way, I noticed there's a new feature of the various info menu.
CTRL+click: Settings that may affect speed.

So, click:various info, ctrl+shft+click:loadtimes,ctrl+click:speed notes.
Icon Names | Onyx | Undocumented Commands | xypcre
[ this user is asleep ]

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

None of the recent additions can possibly have caused a slowdown -- and I see no slowdown here. The only thing that comes to mind: you made excessive use of the new CTB icons feature...
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Stef123

Re: XYplorer slow to open

Post by Stef123 »

admin wrote:The only thing that comes to mind: you made excessive use of the new CTB icons feature...
Using large png files? No, at least not in my case. Since toolbars are stored within ini, I have not replaced them throughout all my ini-files. One instance of slowness was due to thumbs view, btw. So that's one reason that accounted for slow startup. Will try to track down other circumstances, maybe I had custom collumns active ....

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

What does CTB stand for? A fair number of jpeg and pdf files on main drive and backups, but that's always been the case.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

If you don't know that, you're not affected. :)
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Stef123

Re: XYplorer slow to open

Post by Stef123 »

highstream wrote:What does CTB stand for?
Custom ToolBar. It has recently been enhanced by allowing icon formats other than .ico and by zoom-factor tweaks.

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

My toolbar is not particularly custom.
XYplorer toolbar.JPG
XYplorer toolbar.JPG (19.62 KiB) Viewed 1205 times

Post Reply