XYplorer slow to open

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
highstream
Posts: 312
Joined: 10 Apr 2010 21:43

XYplorer slow to open

Post by highstream »

For the last several builds of 15, mainly betas, XYplorer has often been slow to open here after not being open for awhile, taking anywhere from ~10 seconds on up to a lot longer. My first thought was the SSD's power settings (Win 8.1 x64), but why all of a sudden didn't make sense. Now I've confirmed it happens right after reboots too. As I recall, this started with 15 not 14 betas, but I'm not 100% sure. Any ideas? Thanks,

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

Can others confirm?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Filehero
Posts: 2411
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: XYplorer slow to open

Post by Filehero »

admin wrote:Can others confirm?
No(t yet).

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

One other possibility is that it came as the result of a system restore, although I thought it started before that. There was a problem with another program that occurred after that restore, which ultimately required a reinstall of it.

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

The other thing I've encountered for a long time, for at least a year or two and quite consistently, is that the program is slow to close. So slow that it typically takes two clicks on the X, with a few seconds of waiting in between, before it closes. Sometimes the X will show in red, which means the click has registered, but it still sometimes takes a few seconds to react, such as when Comodo's scan is running (once/wk). This continued even after a clean reinstall of Win 8.1 and the program (Dec).

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

Cannot confirm. Start is always fast here (< 400 msec), and close is as instantaneous as can be.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

highend
Posts: 9517
Joined: 06 Feb 2011 00:33

Re: XYplorer slow to open

Post by highend »

Cannot confirm. Start is always fast here (< 400 msec), and close is as instantaneous as can be.
Same here since the beginning.
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

PeterH
Posts: 2594
Joined: 21 Nov 2005 20:39
Location: Germany

Re: XYplorer slow to open

Post by PeterH »

Start: reported 400-650msec
(1 Tab per pane, both show Computer, i.e. topmost entry in tree.
Shown: 4 local drives, 3 NAS shares, 1 [empty] DVD)

End: guessed 100ms (No Save Settings :biggrin: )
If your Save Settings should be slow, you maybe have a harddisk problem?

So: nothing to complain about.
W7(x64) SP1 German
( +WXP SP3 )

kunkel321
Posts: 590
Joined: 10 Jun 2012 03:45
Location: Near Seattle

Re: XYplorer slow to open

Post by kunkel321 »

I see the slow start up, but not the slow close...
The slow start up only happens the first time XY is launched after a reboot (i.e. usually first thing in the morning). This morning it took just over 30 secs. The process xyplorer.exe (in Win Task Man) usually shows up right away, it's just the GUI part that takes a long time. I'm not using MiniTree, but I do have lots of other customizations. I have a bare-bones xyplorer.ini profile (without all my customizations). I call it XYskinny.ini. I'll make a desktop shortcut to it, so I can launch it first thing tomorrow and report back it there's as much of a delay in opening.

Question: I know that antiviruses can cause delays.. Is it possible that having xy customizations such as scripted Custom Columns could exasperate this?? I mean, are those customizations "extra" things that have to be approved by the antivirus on start up?

EDIT: I did a reboot and launched my XYskinny profile. That was definitely NOT a fix... It took almost 2 minutes to launch. I'm actually wondering, if using the /ini=xyskinny.ini switch adds an extra layer of computer processing that I have to wait for... I should also point out that many of my apps take a long time to load after reboot--so this is not just an "xy thing." And yes, I do let the machine fully load Windows and all my 3rd party background utilities before trying to launch xy and other stuff.

PS: I have separate icons for "xyplorer.ini" and "xyskinny.ini." See if you can guess which is which...
Image
ste(phen|ve) kunkel

rd7770
Posts: 44
Joined: 03 Oct 2011 04:36

Re: XYplorer slow to open

Post by rd7770 »

I've posted about this a few times, that the first run after booting is a bit slow, but after that is fast the rest of the time.

In my case, it may be due to having my networked XP computer off most of the time, so when XYplorer starts on my Win 7 system it takes a whlie to figure out what is going on.

highstream
Posts: 312
Joined: 10 Apr 2010 21:43

Re: XYplorer slow to open

Post by highstream »

rd7770 wrote:I've posted about this a few times, that the first run after booting is a bit slow, but after that is fast the rest of the time.

In my case, it may be due to having my networked XP computer off most of the time, so when XYplorer starts on my Win 7 system it takes a whlie to figure out what is going on.
My other programs aren't slow to start after a (cold) startup, so why XYplorer? OTOH, I've assumed the quicker starts after that are cache related.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

The next beta will have means to investigate this. If recent developments are responsible for a slow down at start up (under certain yet unknown conditions) we will eventually track them down and fix what can be fixed.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

TheQwerty
Posts: 4353
Joined: 03 Aug 2007 22:30

Re: XYplorer slow to open

Post by TheQwerty »

Free data point!
XYplorer - Load Times wrote:
XY ver: 	XYplorer 15.00.0202
OS:     	Windows 7 Professional (Service Pack 1), 64-bit
Date:   	2015-03-24 15:28:02


     0 ms:     119 ms - Load Window
   119 ms:      51 ms - Init 0
   170 ms:     129 ms - Init Controls
   299 ms:       7 ms - Get Shell Columns
   306 ms:       7 ms - Init Tree
   313 ms:      25 ms - Load Tree
   338 ms:      13 ms - Load MiniTree
   351 ms:      17 ms - Init 1
   368 ms:      16 ms - Load This Pane
   384 ms:       4 ms - Load Other Pane
   388 ms:      94 ms - Show Window
   482 ms:       1 ms - Load UDC
   483 ms:       5 ms - Load Action Log
   489 ms:       4 ms - Init 2
   492 ms:            - Load Done

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XYplorer slow to open

Post by admin »

Free data point? :?

You mean before "Load Done"?

Code: Select all

   489 ms:       4 ms - Init 2
   492 ms:            - Load Done
Read: at point "489 ms" add duration "4 ms" (the duration of "Init 2") = point "492 ms" (ok, rounding error)

492 ms is the final point. Nothing more is added.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

TheQwerty
Posts: 4353
Joined: 03 Aug 2007 22:30

Re: XYplorer slow to open

Post by TheQwerty »

admin wrote:Free data point? :?
Only meant that as "here's a no-cost set of results for comparison purposes". ;)

Post Reply