XY with WINE on Linux... anybody tried it?

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 23 Jan 2014 21:41

I won't do anything now. I don't have any time left in my day to spare for WINE thoughts.

But (contradicting what i said above :whistle: ) I think I see now how to improve 13.70 a little to make it as good as 13.60 again under WINE. :) Wait for tomorrow's beta...
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 25 Jan 2014 19:10

admin wrote:I won't do anything now. I don't have any time left in my day to spare for WINE thoughts.

But (contradicting what i said above :whistle: ) I think I see now how to improve 13.70 a little to make it as good as 13.60 again under WINE. :) Wait for tomorrow's beta...
Newest beta works fine again!!! :clap:
I think it's time to start a dedicated user project on this. The power of Xyplorer on Linux is really breathing new life into my UNIX experience. I have some spare time coming up, time to write a decent tutorial here :)
Thanks for coming over to answer questions Don, we know you're super busy :)
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 28 Jan 2014 23:04

Image

Still making progress...

Current installation process as follows:

Code: Select all

Xyplorer on Wine 1.7
- Set your $WINEPREFIX location of your choice
- $ winecfg
- $ winetricks vb6run
- $ winetricks allfonts
- $ winecfg (you will probably need to set dpi above 96, especially on smaller laptop screens
- $ winetricks settings fontsmooth=[pick option for your screen: rgbm, bgr, gray, or disabled]
- $ wine <xyplorer_installer.exe>
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 28 Jan 2014 23:59

And thanks to some wizardry with Custom File Associations, we now have native application launching from inside Xyplorer!

Image

Image
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 29 Jan 2014 07:01

:appl: I see and I believe!

You still get the error at startup?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 29 Jan 2014 11:58

admin wrote::appl: I see and I believe!

You still get the error at startup?
More interesting developments this morning! So the standard start-up error is still there as you can see below. However, I have a theory the solution may be much easier than anticipated.
Image

I have also been doing some performance testing but the results are inconclusive. Copying performance is pretty much identical to native Windows. Searching on the other hand is slower as you can see below:
Image

Image

Now the last time I discovered that Xyplorer started throwing the following error, seemingly at random, after prolonged used. I did make a post about this and I remember you (Don) said there's a ton of stuff going on at that stack. Well... I have been bug hunting :D
Image

So I was able to sandbox a xyplorer data-set when I randomly hit that error on a fresh install. Turns out I was able to track the issues down to the "Panes" folder and more specifically to a set of keys in the "Pane.ini" file. Here is the culprit:

Code: Select all

[ListBrowse]
Sort=-65536
Num=4
Style=1079
View=0
Date=0
Time=0
Age=0
Day=0
Visible=111111000000
Columns=Name.270,Ext.78,Size.108,Type.60,Modified.148,Created.148,Accessed.115,Attr.47,Len.28,Tag.50,Comment.75,Tags.75,
I cross-checked with a clean xyplorer install that does work under the same wine environment and in that install the value of the "Num" key is =2 instead of =4. And indeed, if I edit the value back to 2 the crashing xyplorer instance runs fine once more. The error first started appearing after a Custom Copy job I did for the performance test. What does that Num key stand for? This is good news regardless, since we could easily implement an integrity check of the xyplorer files under Python or bash. Progress!!! :appl: Now the big question is: is the start-up error related in any way to our Plist21 error? Perhaps a setting in another ini file?
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 29 Jan 2014 12:38

Thrilling! I'll check this ASAP (once I have VB running on w8).
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 29 Jan 2014 21:03

Num=4 refers to the format of the bytes in the Size column. 4 = MB, 2 = KB (rounded).

I don't see how this could be a problem.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 30 Jan 2014 10:12

admin wrote:Num=4 refers to the format of the bytes in the Size column. 4 = MB, 2 = KB (rounded).

I don't see how this could be a problem.
Bug is now confirmed: switching the data size columns from kB to mB causes a xyplorer to crash. Switching them back stops the plist@21 error from appearing!
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 30 Jan 2014 21:11

40k wrote:
admin wrote:Num=4 refers to the format of the bytes in the Size column. 4 = MB, 2 = KB (rounded).

I don't see how this could be a problem.
Bug is now confirmed: switching the data size columns from kB to mB causes a xyplorer to crash. Switching them back stops the plist@21 error from appearing!
Bug does not happen under WIndows. I cannot explain it, there is nothing suspicious.

So under WINW this even happens while the app is running (not just at startup)? What about switching to GB or TB?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

serendipity
Posts: 3355
Joined: 07 May 2007 18:14
Location: NJ/NY

Re: XY with WINE on Linux... anybody tried it?

Post by serendipity » 30 Jan 2014 21:42

Thanks 40k for running all these tests. Good to know it's working in certain conditions.
I removed ubuntu only recently and could have tested this bug.
Will try to reinstall this weekend.

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 02 Feb 2014 10:36

serendipity wrote:Thanks 40k for running all these tests. Good to know it's working in certain conditions.
I removed ubuntu only recently and could have tested this bug.
Will try to reinstall this weekend.
Any information is welcome. At the moment the beta builds for 13.70 seem to be holding up nicely. I'm currently working on some issues with font rendering in Wine. Has nothing to do with Xyplorer itself but it does impact the user experience. If anyone is interested I'll post the python script that allows Xy to launch native applications in unix.

More performance testing: As you can see, I/O operations under unix do take a performance hit. The test was performed by copying data between 2 encrypted drives. As such, I'm not sure how much of the performance drain can be attributed to the encryption overhead onunix being less efficient.

native (failed items are sandbox lock files)
Image

wine
Image
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 02 Feb 2014 19:25

Ok so I've put XY through pretty much a day of hard use and it hasn't locked up on me since. However, I did avoid some known traps (such as an arbitrary bug that "sort of" happens when switching column 'size' from kB to MB). The farther I dig into Xy the more oddities I find. For example, for some reason, this happened:

Menu bar icons just disappeared, don't know why. I actually think this looks pretty nice.
Image

Also, turns out that I/O performance is indeed fine. As long as you have a steady stream of data. Here I tried to copy 10gb of /dev/zero from one drive to the other:
Image
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

admin
Site Admin
Posts: 49770
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: XY with WINE on Linux... anybody tried it?

Post by admin » 05 Feb 2014 12:30

FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

40k
Posts: 234
Joined: 09 Dec 2011 21:25

Re: XY with WINE on Linux... anybody tried it?

Post by 40k » 05 Feb 2014 13:06

13.70.0113 runs the same like previous builds. Same start-up error. Think the issue on Windows was unrelated.
I develop scripts that integrate media functionality into Xyplorer.
Hash - Twitch.tv in VLC (NEW 2.0!) - FFmpeg GUI - Youtube downloading
XYplorer for Linux! Tutorial

Post Reply