HELP Please with XYPlorer After PC Crash

Please check the FAQ (https://www.xyplorer.com/faq.php) before posting a question...
kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

HELP Please with XYPlorer After PC Crash

Post by kodyman »

A while ago my laptop totally locked up for some reason. May have had too many things loaded and trying to run at the same time.
After waiting a while to see if it would fix itself, it wouldn't. Couldn't even bring up Task Manager. So I turned off the power, waited a bit and powered back up. Everything seems OK except XYplorer. When I start it it looks like this:
XYp Screen 1 - 1-13-22.png
XYp Screen 1 - 1-13-22.png (51.73 KiB) Viewed 192 times
When I tried starting it I did get a screen that says the location it was trying to open was no longer available. I didn't get a screenshot of it, and it hasn't popped up since. I know that when the lock-up occurred one of my tabs was focused on a search for files that had been created in the last 5 mins.

I had been running version 22.30.0200 at the lock-up. I thought maybe if I installed the current version 22.70.0000 that might fix it. WRONG!
Fortunately, I had auto-backup turned on and using WE was able to get to the folder. The back-ups are a couple of hours old so I may loose some tags, but at least I have them up to that point.
XYp Backup files 1-13-22.png
XYp Backup files 1-13-22.png (12.24 KiB) Viewed 192 times
Should I just copy these to the XYplorer directory shown in the first screen to get everything back the way it should be?

Additional:
I just tried some of the short-cut keys and it seems at least some of these are working. Ctrl+F12 allowed me to show/hide what looks to be a default Toolbar. But it isn't showing me the Menu Bar and searching keystrokes couldn't find one for the Menu Bar.

If you need any other info let me know.

Thanks!

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Never mind. After a good while I got most of it working again as before.

Moderator: you can delete the OP so it doesn't needlessly show up on the board.

Please disregard the delete OP for now. I may have some different questions after all.
I am now having the problem of unable to save setting on closing XY.
Like viewtopic.php?f=2&t=21752&p=178233&hili ... ed#p178233

I am going through this and other old posts and help file to try and figure out. It could be where my dat (fv, tag etc) files are located. Not sure if they should be in the main program folder or DATA folder. Or if it is something else.
I don't have time to mess with it much during my day job but I'll figure it out. Using WE isn't near as easy as what I'm used to.

highend
Posts: 11224
Joined: 06 Feb 2011 00:33

Re: HELP Please with XYPlorer After PC Crash

Post by highend »

They are in the data folder
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Thank You highend!

OK. I am still having problems. A little more help if you will. I will try to explain & ask my question clearly.
I have seen in the installation text file and other various places what files are supposed to be in the C:\Program Files (x86)\XYplorer folder. But I haven't found anything to do with what is/should be in the Data folder.

Here is what I am showing:
XYp x86 Prog Fldr.png
XYp x86 Prog Fldr.png (36.79 KiB) Viewed 134 times

And here is what is in the data folder:
xyp Data Fldr 002.png
xyp Data Fldr 002.png (30.8 KiB) Viewed 134 times

I realize the two config.ini files in the Data folder may be in the wrong place? I have moved them around at different times.
Where SHOULD the config files be? Should they be named something else?
The one named XYplorer.ini is the one that has my my license info in it The other one is an ini that I did a Save As from the File menu as a backup when I was using ver 22.10.0000 and was the one that showed up in the Title Bar as being used when I would start the program before the PC lockup. But, it doesn't have my license info showing in it.

Are there any other .dat files that should be showing in the Data folder?

For a basic installation should Startup.ini contain anything other than

Code: Select all

[Appdata]
Path=%APPDATA%\XYplorer
I may have a few follow-up questions after I get the basics set back up. If I wasn't for all of the tags, labels & comments I have for a BUNCH of files I would just uninstall and start over.

Thanks again!

PeterH
Posts: 2612
Joined: 21 Nov 2005 20:39
Location: Germany

Re: HELP Please with XYPlorer After PC Crash

Post by PeterH »

startup.ini defines where the xydata folder is. So ok.
(*Must* point to a folder XY is allowed to modify.)

You talk about 2(!?) config.ini - what do you mean?
The main configuration file of XY is XYplorer.ini
I don't know of a config.ini

Your "XYplorer-v22_10_000 conf.ini" seems to be some hand-made copy (to save something?)
W7(x64) SP1 German
( +WXP SP3 )

highend
Posts: 11224
Joined: 06 Feb 2011 00:33

Re: HELP Please with XYPlorer After PC Crash

Post by highend »

CustomCopyBlacklist.dat belongs in the data folder

The rest looks ok
But, it doesn't have my license info showing in it.
That's normal
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Well, I'm getting there.

PeterH... In my earlier post I used the term config.ini improperly. It was meant to mean the two .ini files in that folder that contain the configuration information for the program. There isn't one just named config.

highend
Here are two screenshots of what I have now. Main XY then Data folder.
XYp 1-16-22 139P.png
XYp 1-16-22 139P.png (80.95 KiB) Viewed 98 times
XYp Data Fldr 1-16-22 147p.png
XYp Data Fldr 1-16-22 147p.png (80.27 KiB) Viewed 98 times

When I started XYp it came up with the above screen. Except it was only displaying the Name column. I added the Size, Modified and Created for the screenshot.
Notice the Menu bar is not displaying (File, Edit, View etc). I have searched through the settings, help file and user guide for "Menu", Show Menu", "Toggle Menu" and a number of other keywords. I am not seeing anything. How can I get it to show? I even re-booted to make sure there were't any old whatever could still be in memory.

I am happy to say that my tags, labels, comments and Catalog are back in tack. :D
But my folder view settings, favorite files, favorite folders and tab settings are still missing. I added Favorite Folders and Files to the Toolbar but they do nothing when clicked. Not sure if I am missing another .dat file with those if that is where they are stored?
If I could get the Menu Bar back maybe I could load an old saved setting and get them back.

Any recommendations for getting the Menu Bar back?

Thanks!

highend
Posts: 11224
Joined: 06 Feb 2011 00:33

Re: HELP Please with XYPlorer After PC Crash

Post by highend »

Try CTRL+SHIFT+ALT+F12
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Nope. Didn't work.
Tried all at once and each separately in order.

highend
Posts: 11224
Joined: 06 Feb 2011 00:33

Re: HELP Please with XYPlorer After PC Crash

Post by highend »

Sorry, my own keyboard shortcut for it :party:

Open a dos box, navigate into your installation folder and execute:

xyplorer.exe /script="::#1061;"

or edit your XYplorer.ini file:
ShowMainMenu=1
in the Layout section
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Sorry, it has been a LOOONG time since I have done anything in the DOS box.
If I did what you meant I get this:
Command box.png
Command box.png (34.9 KiB) Viewed 90 times

I am able to bring up the Address Bar in the Toolbar. Anything I can try there?

jupe
Posts: 1795
Joined: 20 Oct 2017 21:14
Location: Win10 21H2 120dpi

Re: HELP Please with XYPlorer After PC Crash

Post by jupe »

The contents of your Data folder should be in the path that was shown in the screenshot you provided of Startup.ini, it looks like you have some files in the wrong spot so half your config is in the wrong folder, it shouldn't be under Program Files.

highend
Posts: 11224
Joined: 06 Feb 2011 00:33

Re: HELP Please with XYPlorer After PC Crash

Post by highend »

C:\Windows\System32 is not the installation folder...
Anything I can try there?
::#1061;

and jupe is right, why the hell are you using

Code: Select all

[Appdata]
Path=%APPDATA%\XYplorer
but put all your stuff under the XYplorer installation folder?...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

kodyman
Posts: 215
Joined: 09 Apr 2011 04:05

Re: HELP Please with XYPlorer After PC Crash

Post by kodyman »

Anything I can try there?
::#1061;
That did it :appl: :party:

and jupe is right, why the hell are you using
CODE: SELECT ALL

[Appdata]
Path=%APPDATA%\XYplorer
but put all your stuff under the XYplorer installation folder?...
Up in the earlier posts I mentioned I had found in the user guide that the basic Startup.ini looked like this and whether anything else should be added.

Code: Select all

[Appdata]
Path=%APPDATA%\XYplorer
Since it wasn't addressed I took it as being correct and left it alone. Do I even need it? And I posted a screenshot of the Data folder showing both the .dat and .ini files asking what should be there. I must have misunderstood the answer and didn't move the .ini files to the program folder. My bad!
I will move the .ini files to the main program folder.

Thanks,

jupe
Posts: 1795
Joined: 20 Oct 2017 21:14
Location: Win10 21H2 120dpi

Re: HELP Please with XYPlorer After PC Crash

Post by jupe »

kodyman wrote: 16 Jan 2022 21:51 I will move the .ini files to the main program folder.
No, don't do that, try reading my last post.

Post Reply