Startup crash with altered [Register] key

Things you’d like to miss in the future...
Post Reply
Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Startup crash with altered [Register] key

Post by Chris Wood »

I was getting this error on startup:
Error 9 (00000009)
Desc Subscript out of range
Dll 0
Proc IB@75

Source XYplorer
XY ver 7.90.0126
OS Vista (Service Pack 1)
Date 6/04/2009 22:19:54
I worked out it was because of the line
dc=0
in the [Register] section of XYplorer.ini. Changing it to dc=1 fixed the problem (I'm a registered user). Not sure how it got to be 0, maybe it was me... anyways what's your policy on the ini file? Is it okay that screwing with it can cause XYplorer to crash?


(P.S. I've finally installed XYplorer on my home computer, as always it's great to come back and see heaps of cool new features and an even nicer interface :))

qbvii
Posts: 1
Joined: 09 Apr 2009 06:56

Re: Startup crash with altered [Register] key

Post by qbvii »

I'm frequently getting the same exact error message about once a month. The first couple of times I spent a couple of hours rebuilding searches etc; then I made a backup of the it. :-)

This time (thanks to your post!) I went looking at the .ini discovered that the .ini file was completely wiped - still there, but 0 bytes and empty! On restoring from my backup, xyplorer starts just fine.

Thank you for pointing to the ini. Why is this happening?

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Startup crash with altered [Register] key

Post by admin »

I cannot reproduce the dc=0 crash here.

The error 9 stuff should be fixed in the current BETA version.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Post Reply