AAC audio bitrate in preview is wrong

Things you’d like to miss in the future...
Post Reply
Lyon1
Posts: 26
Joined: 07 Apr 2019 12:07

AAC audio bitrate in preview is wrong

Post by Lyon1 » 16 Feb 2020 17:02

-
Last edited by Lyon1 on 18 Apr 2020 01:10, edited 1 time in total.

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: AAC audio bitrate in preview is wrong

Post by admin » 27 Feb 2020 10:03

By preview details you mean the file's tool tip (aka File Info Tip)?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Lyon1
Posts: 26
Joined: 07 Apr 2019 12:07

Re: AAC audio bitrate in preview is wrong

Post by Lyon1 » 04 Mar 2020 15:11

-
Last edited by Lyon1 on 18 Apr 2020 01:10, edited 1 time in total.

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: AAC audio bitrate in preview is wrong

Post by admin » 04 Mar 2020 16:08

Where you get the correct value, and how is it wrong (e.g. systematically? always the double or so...?).
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Lyon1
Posts: 26
Joined: 07 Apr 2019 12:07

Re: AAC audio bitrate in preview is wrong

Post by Lyon1 » 05 Mar 2020 14:19

-
Last edited by Lyon1 on 18 Apr 2020 01:10, edited 1 time in total.

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: AAC audio bitrate in preview is wrong

Post by admin » 05 Mar 2020 14:27

Can you send (or link) me some test files along with the correct values?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Lyon1
Posts: 26
Joined: 07 Apr 2019 12:07

Re: AAC audio bitrate in preview is wrong

Post by Lyon1 » 02 May 2020 23:04

Just discovered that XY reports correct bitrate for AAC encoding as long as they're encoded as m4a and not AAC.
For what it's worth.

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: AAC audio bitrate in preview is wrong

Post by admin » 04 May 2020 12:13

Encoded or named?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Lyon1
Posts: 26
Joined: 07 Apr 2019 12:07

Re: AAC audio bitrate in preview is wrong

Post by Lyon1 » 04 May 2020 14:37

Use aac codec for audio files inside an m4a container and it's good.
Use only the raw aac codec/format for audio, and XY will sometimes see the correct bit rate, or something close, and sometimes it's completely off.
Guess most apps have standard support for m4a/mp4 containers, less so for the raw aac codec.
Probably fixable with a codec pack for Win, but there's no need now.

https://en.wikipedia.org/wiki/Advanced_Audio_Coding
https://en.wikipedia.org/wiki/MPEG-4_Pa ... ersus_.M4A

Post Reply