Icons next to item name not reflecting system settings

Things you’d like to miss in the future...
Post Reply
fuego126
Posts: 6
Joined: 25 May 2019 23:50

Icons next to item name not reflecting system settings

Post by fuego126 » 26 May 2019 00:13

Hi.. strange item in XYPlorer... when I view indd files in Windows, the correct adobe indesign "icon" appears next to the name in Details mode... however, when I view that same entry in XYP - it shows a generic icon. I verified the ico is setup correctly in windows via 3rd party tool... reboot, recache and restart of XY does not correct. Any thoughts? Seems to be the only icon that does not display correctly next to the name in details mode. Thx!

jupe
Posts: 1299
Joined: 20 Oct 2017 21:14
Location: 2004 x64

Re: Icons next to item name not reflecting system settings

Post by jupe » 26 May 2019 05:04

I haven't used Adobe InDesign, so I am only guessing, and assuming you are using x64, but problems like this are usually caused because when the program is installed it incorrectly creates the icon registry entries using the %PROGRAMFILES% variable, so when you use your 3rd party tool to check, what is the actual file path for the icon that is used? (and before replying, make sure the program you are using isn't resolving it itself first) If is is using that variable, change it to %PROGRAMW6432% instead.

Another way to mitigate the issue, without using the registry is just to use XY Custom File Icons, and set the icon manually just for XYs use, if you can't figure out the registry solution.

https://www.xyplorer.com/release_12.40.php#CFI

Anyway this issue won't be an XY bug, but an Adobe installer issue which doesn't account for 32bit software on a 64 bit OS.

admin
Site Admin
Posts: 49382
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Icons next to item name not reflecting system settings

Post by admin » 26 May 2019 11:33

Could you tell me the full filename including extension?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

fuego126
Posts: 6
Joined: 25 May 2019 23:50

Re: Icons next to item name not reflecting system settings

Post by fuego126 » 26 May 2019 22:33

The indesign extension is .indd - it is indeed a 64bit program. It installed correctly because the indd extension icon appears correctly everywhere except xyplorer... perhaps the 32 bit nature of XY is the issue...?

The registry edit value for the iconfile is the path to the icons.dll inside C:\Program Files - I changed this to an icons.dll pointing to C:\Program Files <x86>, restarted XY and it still shows incorrectly (windows shows correctly).

The custom icon route worked fine though... so thanks for the help!

highend
Posts: 9257
Joined: 06 Feb 2011 00:33

Re: Icons next to item name not reflecting system settings

Post by highend » 26 May 2019 22:51

Where is the full filename including extension Don asked for?
C:\Program Files <x86>
That folder does not exist...
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

Post Reply