Error 93 (0x0000005D)

Things you’d like to miss in the future...
Post Reply
Posts: 76
Joined: 06 Apr 2019 04:21

Error 93 (0x0000005D)

Post by FKF5482 » 16 Apr 2019 10:32

Hello! I am getting an error for certain folders when im trying to save the folder view. The error is:


I did everything that i could trying to pinpoint the conditions for the error to appear and what i've found is:

I have two subfolders inside a folder, lets say subfolder1 and subfolder2. I enter subfolder1, set the thumbnail size that i want and then save the FVS.
Once the FVS is saved for subfolder1, i cannot access the subfolder2 because of the error i've mentioned.
Same thing happens if i do it the opposite way, when i set thumbnail size for subfolder2 and then save the FVS i'm unable to access the subfolder1.

Also, if i enter one of the subfolders and set thumbnail size without saving the FVS i can access the other folder normally.

To do this testing i had to delete the FVS.DAT every time because when the error appears for a given folder, that folder is permanently inaccessible.

The Folder names of the two subfolders are:

[Kalo-ena (kales photo)] Arxikes omorfies
[Kalo-ena (kales photo)] ypsiles! - mystikes eksodoi

I've tried renaming the subfolders, removing brackets etc and the error still occurs.
I have a lot of other folders with [] and () in their names and they work just fine.

If you have further questions please let me know.

As always thanks in advance :)

Posts: 76
Joined: 06 Apr 2019 04:21

Re: Error 93 (0x0000005D)

Post by FKF5482 » 22 Apr 2019 12:00

Hello again, a "small" update (lol) on what i've managed to find.

In the weekend i had time to try to get to the bottom of this as much as i could so i've done a lot of folder naming tests and i've found some more info and a solution for this.

There are three situations you can encounter this error:
A)When you try to save a folder view. (The error i've posted in my previous post)
B)Trying to remove a folder view. (Run-time error '93'; invalid pattern string) and XYplorer will crash.
C)Trying to go up or back. (The error i've posted in my previous post)

Seems the problem lies with the use of dash/minus "-" when its contained inside brackets [] with text before and after the dash in a folders name. However folder naming of this kind will not always result in an error. I've tried more than 100 different folder names and i wasn't able to find a pattern, the problem seems to be with certain combinations of letters. Capital letters or not does not seem to affect it. A few Examples:

[Ab-Aaaa] test ERROR
[Ab-aaaa] test ERROR
[ab-aaaa] test ERROR
[Aab-aaaa] test ERROR
[Aaab-aaaa] test ERROR
[aaab-aaaa] test ERROR
[ab-aa] ERROR
[ac-aa] ERROR
[aaaa-a] test 2 OK
[aaaa-aa] test 2 OK
[aaaa-aaa] test 2 OK
[aaaa-aaaa] test 2 OK
[Aaaa-aaaa] test 2 OK
[Aaaa-Aaaa] test 2 OK
[aq-aa] ERROR
[ax-aa] ERROR
[az-aa] ERROR
[zaz-aa] ERROR
[zz-aa] ERROR
[zz- aa] ERROR
[zz -aa] OK

Having a problematic folder name its not a problem unless you save the folder view for it.
Then you will not be able to open any folder in the same level, below or above* it, that does not have a saved folder view for it.
(*When you are trying to go up or back when you are in the same level as the problematic folder.
However that seems way to random, some times seems to be affected by the name used on the parent folder also,
and i don't feel i have enough information for the third type of error, the first two errors i was able to reproduce every time.)

Lets say i have a folder named ParentFolder, that contains three subfolders, named [aaaa-a], [aaaa-aa] and [ab-aaaa].
The third folder [ab-aaaa] is the problematic folder name.

So it's like this:
C:\ParentFolder\[aaaa-a] *1st subfolder
C:\ParentFolder\[aaaa-aa] *2nd subfolder
C:\ParentFolder\[ab-aaaa] *3rd subfolder

I will use 1st, 2nd and 3rd subfolder in my examples below to save some time and maybe some confusion.

If i save the folder view for the 1st sufolder and then the 3rd subfolder (problematic one), i will be able to open the 1st and 3rd subfolder but i will get an error if i try to open the 2nd subfolder. I will be able to open the 1st subfolder because i saved the folder view before saving a folder view for the problematic 3rd subfolder. However i will not be able open the 2nd subfolder because it does not have a folder view saved for it.
In other words the moment you save a folder view for a problematic folder name, it blocks any other folder from opening in the same level or below that does not have a saved folder view for it.

Also if you try to remove the folder view for the 1st subfolder you will get an error and XYplorer will crash.

If you try to rename the problematic folder it will not work, you will still get the error.
The only way to solve this, is to first delete the folder view for the problematic folder and then rename it.
That's why renaming didn't work as i've mentioned in my previous post, you have to remove the problematic folder view first.
Either remove the brackets or put a space before the dash "-" (assuming you want to keep this type of naming scheme)
like this:

before [ab-aaaa]
after [ab -aaaa]

So if somebody encounters this error in the future follow these steps to save you a lot of frustration.

A) When you see the error, that means the problematic folder exists in the level you are currently in or above it.
That narrows it down by a LOT!
B) Locate all the folders that use similar naming scheme as shown in the examples above.
C) Start removing the folder views one by one. If you get an error and XYplorer crashes, you tried to delete the wrong folder view, open XYplorer again and continue. The moment you are able to remove the folder view without crashing means you found the problematic one. If all of them end up crashing XYplorer, go one level up and repeat the process.
If you get the error trying to go back or up, close the current tab and navigate to the folder you want starting from the upper level folders till you reach the one you want.
D) After it's succesfully deleted, rename it and save the folder view.

It's not a perfect solution for sure but its way better than having to delete the fvs.dat thinking somehow it got corrupted and losing all your saved folder views, only to encounter the error again when you re-save the problematic folder view.

I hope that will help someone in the future, although hopefully sooner ot later it will get fixed by the developer.

Sorry for the length of the post but i've tried to provide detailed information for both the developer and the average user as much as i could. :)

Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10

Re: Error 93 (0x0000005D)

Post by admin » 06 May 2019 10:13

Okay, thanks for the report. I could confirm it and most likely fix it. Please try the next beta version.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Posts: 76
Joined: 06 Apr 2019 04:21

Re: Error 93 (0x0000005D)

Post by FKF5482 » 06 May 2019 11:11

Thats nice to hear, thank you. I will let you know once the beta is released :)

Posts: 76
Joined: 06 Apr 2019 04:21

Re: Error 93 (0x0000005D)

Post by FKF5482 » 07 May 2019 08:44

The beta version fixed the issue, thank you very much :)

Post Reply