Settings are erroneously saved

Things you’d like to miss in the future...
mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Settings are erroneously saved

Post by mikeyww » 21 Mar 2019 00:12

Although my config specifies that settings should not be saved on exit, sometimes they are saved anyway! The issue is with tabsets. I do not want them saved. I have set the MRU list without tabsets marked. I am not sure how to reproduce the problem, but it is certainly frustrating! The effect is that when I run XYplorer, I see the most recently used tabs instead of just my default tabs that I previously saved manually.

Image

Image

Version 19.80.0100

Code: Select all

Operating system           : Microsoft Windows 7 Professional 
OS version                 : 6.1.7601
Service pack major version : 1
Service pack minor version : 0
Free physical memory       : 11182600
Total physical memory      : 17052119040
PC manufacturer            : TOSHIBA
PC model                   : PORTEGE R930
CPU                        : Intel64 Family 6 Model 58 Stepping 9
OS bitness                 : 64
CPU bitness                : 64
BIOS manufacturer          : TOSHIBA
BIOS name                  : Default System BIOS
BIOS version               : Version 6.80  
Motherboard manufacturer   : TOSHIBA
Motherboard product        : PORTEGE R930
Motherboard version        : Version A0
Display                    : Intel(R) HD Graphics 4000
Display width              : 1024
Display height             : 768
DPI                        : 120

SammaySarkar
Posts: 4161
Joined: 12 Mar 2014 17:27
Location: Asteroid B-612 / Dhaka
Contact:

Re: Settings are erroneously saved

Post by SammaySarkar » 21 Mar 2019 05:25

"Save changes to disk immediately"
Last edited by SammaySarkar on 21 Mar 2019 11:42, edited 1 time in total.
Reason: irrelevant

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 21 Mar 2019 11:39

SammaySarkar wrote:
21 Mar 2019 05:25
"Save changes to disk immediately"
This previous post is mysterious. I don't care what is saved immediately. I do not want my active tabsets automatically saved, regardless of timing. Furthermore, "Save changes to disk immediately" does not even refer to tabsets, so this post seems irrelevant. In addition, the behavior that I have described is not consistent. It is usually not a problem but sometimes is.

SammaySarkar
Posts: 4161
Joined: 12 Mar 2014 17:27
Location: Asteroid B-612 / Dhaka
Contact:

Re: Settings are erroneously saved

Post by SammaySarkar » 21 Mar 2019 11:41

Oh right sorry. I don't know what I was thinking :oops:

Try disabling this: Configuration > Tabs and Panes > Tabs > Auto-save tabsets on switch

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 21 Mar 2019 12:18

SammaySarkar wrote:
21 Mar 2019 11:41
Try disabling this: Configuration > Tabs and Panes > Tabs > Auto-save tabsets on switch
Thank you for the idea. Unfortunately, it will not work because that switch is already disabled.

admin
Site Admin
Posts: 46881
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Settings are erroneously saved

Post by admin » 21 Mar 2019 16:35

You unticked "Configuration | General | Startup & Exit | Save Settings | Save settings on exit", so nothing should be saved on Exit, regardless of any other ticks. And according to my code it is not saved. Are you sure the timestamps on those tabset files are set to the moment of app exit?

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 21 Mar 2019 17:21

admin wrote:
21 Mar 2019 16:35
You unticked "Configuration | General | Startup & Exit | Save Settings | Save settings on exit", so nothing should be saved on Exit, regardless of any other ticks. And according to my code it is not saved. Are you sure the timestamps on those tabset files are set to the moment of app exit?
Good idea for me to check this. I will do it as soon as the problem comes up next. I have experienced this problem several times and so am confident that the issue will continue to recur periodically, probably next at some point in the upcoming 1-2 weeks. I have even wondered if I am accidentally and unknowingly saving the tabset somehow, but I don't think so.

Stay tuned....

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 28 Mar 2019 00:10

Problem has recurred today. XYplorer is starting with my saved tabs plus one on the left that I did not explicitly save. "Panes" subdirectory's files are not timestamped today, except "2\t\tab_3.ini". Within the "Panes" folder are folders "1", "2", and "mike1". "1" and "2" have "pane.ini" and "t\pane.ini". In "2", both INI files list the same path under "General". In "1", "pane.ini" lists the correct path for the left side, but "t\pane.ini" lists the extra path that should not be appearing.

admin
Site Admin
Posts: 46881
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Settings are erroneously saved

Post by admin » 28 Mar 2019 10:33

Could it be that you ran a search in that pane?

Open that file "2\t\tab_3.ini", does it begin with something like this?

Code: Select all

; XYplorer 19.80.0126 configuration file: tabwise find settings

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 28 Mar 2019 12:25

Code: Select all

; XYplorer 19.80.0100 configuration file: tabwise find settings
; Windows 7 Professional (Service Pack 1), 64-bit, Build 7601
; 2019-03-27 18:58:44
Why would running a search save a tabset and open it on the next run? That would be unexpected.

admin
Site Admin
Posts: 46881
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Settings are erroneously saved

Post by admin » 28 Mar 2019 12:31

It should just save the find settings used for that search tab (and optionally the search results cache).

The tabset is not saved nor restored. At least I cannot reproduce this here.

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 28 Mar 2019 12:36

Thank you. I will report again when the problem recurs.

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 28 Mar 2019 12:44

I am running a portable installation in a directory called E:\data\utils\XYplorer\. Below are the contents of Startup.ini.

Code: Select all

[Appdata]
; Path=%appdata%\XYplorer
Path=E:\data\utils\XYplorer\Data
I closed the erroneous tab and then saved the tabset. Upon restarting XY, I still find that the erroneous tabset appears. Isn't this unexpected? File 1\t\pane.ini still lists the erroneous path.

admin
Site Admin
Posts: 46881
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Settings are erroneously saved

Post by admin » 28 Mar 2019 12:53

I think I know what to do: On "Exit without Saving" all temporary folders ("t\") under Panes are removed. Next version...

mikeyww
Posts: 54
Joined: 25 Feb 2019 13:08

Re: Settings are erroneously saved

Post by mikeyww » 28 Mar 2019 13:30

Thanks.

Post Reply