Page 1 of 1

Default file manager stops working properly after a while

Posted: 19 Mar 2019 13:33
by alfi286
Initially doing things in Windows that trigger XY to open a tab as the default file manager works fine - such as putting %appdata% in the Windows run dialog.

After a while of use though this stops working properly and instead XY just gets the focus and shows no tab for the thing opened.

Closing XY and attempting the operation again and things are ok again.

Re: Default file manager stops working properly after a while

Posted: 19 Mar 2019 17:28
by admin
After a while ...? Is time the factor? Or a certain number of tabs opened?

Re: Default file manager stops working properly after a while

Posted: 28 Mar 2019 12:52
by alfi286
Time seems to be the factor. It has just gone into the funny state again with only one tab open on the left and one on the right.

I am double clicking my different drives in 'This PC' and all it does is set focus across to XY. But no new tab is opened and neither existing tabs is the thing clicked.

Now, interestingly, closing XY and re-opening it multiple times does not fix the issue. But closing it and then double clicking a drive opens up XY with a new tab for the drive. And it continues to work after.

Re: Default file manager stops working properly after a while

Posted: 28 Mar 2019 13:17
by alfi286
The registry entries for the mechanism seem to be ok with 'XYplorer' set as the defalt action for 'HKEY_CLASSES_ROOT\Drive\Shell' and the command action set to "C:\Program Files (x86)\XYplorer\XYplorer.exe" "%1"

Perhaps there is some difference between a fresh launch of XYplorer and whatever it does when it is already running?

Re: Default file manager stops working properly after a while

Posted: 28 Mar 2019 16:39
by admin
What are your settings here?

Configuration | General | Startup & Exit | Open command line start path in new tab
Configuration | General | Startup & Exit | Allow multiple instances
Configuration | General | Startup & Exit | Open new instance always

Re: Default file manager stops working properly after a while

Posted: 29 Mar 2019 09:43
by alfi286
Configuration | General | Startup & Exit | Open command line start path in new tab [OFF]
Configuration | General | Startup & Exit | Allow multiple instances [ON]
Configuration | General | Startup & Exit | Open new instance always [OFF]

Re: Default file manager stops working properly after a while

Posted: 29 Mar 2019 12:02
by admin
Can you give me a step-by-step way to reproduce the undesired behavior?

Re: Default file manager stops working properly after a while

Posted: 29 Mar 2019 14:20
by alfi286
Ok, it is currently in the broken state. So XY is running and has one tab open in the left panel and 2 in the right.

So

1. Double click 'This PC'. This is just a normal windows explorer Window.
2. Double click drive C

Focus switches to XY but no new tab is opened and none of the 3 existing tabs are the C drive.

Re: Default file manager stops working properly after a while

Posted: 29 Mar 2019 14:26
by alfi286
Turning on 'Configuration | General | Startup & Exit | Open new instance always' opens a new instance with the expected tab.

But turning that back off goes back to not opening the tab.

Re: Default file manager stops working properly after a while

Posted: 30 Mar 2019 17:35
by admin
alfi286 wrote:
29 Mar 2019 14:20
2. Double click drive C
Where do you double-click?

Re: Default file manager stops working properly after a while

Posted: 01 Apr 2019 12:31
by alfi286
I have attached a picture of where I double click.
2019-04-01 11_29_04-This PC.png
2019-04-01 11_29_04-This PC.png (27.97 KiB) Viewed 176 times

Re: Default file manager stops working properly after a while

Posted: 02 Apr 2019 17:19
by admin
In your current XYplorer instance run this through the address bar:

Code: Select all

showcommandfromotherinst;
When you now do your double-click a message should be shown in XYplorer... if yes, what is that message?