Page 1 of 1

Scripting Unmatched delimiter [types] ")" [closing]

Posted: 12 Nov 2018 20:37
by Zardoz2293
Seems that the Scripting engine should throw an error on an unmatched closing parenthese ")".

Code: Select all

msg $NameStatus . " entire folder structure for <br><br>'$TypeFind'<br><br>Proceed?", 1);

Thread of discussion below:
viewtopic.php?f=3&t=19664&p=164016#p164016

Thank you

Re: Scripting Unmatched delimiter [types] ")" [closing]

Posted: 13 Nov 2018 00:04
by klownboy
Check "Syntax Checking" under the Scripting menu. That will yield a scripting dubious syntax message. I would think that should be sufficient.

Re: Scripting Unmatched delimiter [types] ")" [closing]

Posted: 13 Nov 2018 05:54
by Zardoz2293
klownboy wrote:
13 Nov 2018 00:04
Check "Syntax Checking" under the Scripting menu. That will yield a scripting dubious syntax message. I would think that should be sufficient.
So what's the equivalent in-scripting command to enable when executing the script?

Thanks

Re: Scripting Unmatched delimiter [types] ")" [closing]

Posted: 13 Nov 2018 06:03
by jupe

Code: Select all

#758;
you would have to disable it at the end of the script though or it will stay enabled, I think if you are fairly new to scripting it would be wise to just leave it enabled though anyway, you would only notice a difference if you make scripting errors.

Re: Scripting Unmatched delimiter [types] ")" [closing]

Posted: 13 Nov 2018 08:20
by Zardoz2293
Thanks. Actually, I can't imagine why I'd want syntax checking off.

Re: Scripting Unmatched delimiter [types] ")" [closing]

Posted: 13 Nov 2018 09:15
by highend
You'll notice soon enough (if you use scripts made by other people that don't use the same setting) :whistle: