Page 1 of 2

Will not set as default file manager

Posted: 03 Nov 2018 20:18
by FatIgor
https://www.xyplorer.com/faq-topic.php?id=dfm

Yes I have seen this and that is what I have tried, and this worked with previous version.

I've installed 19.3, and it is refusing to set as default file manager.

Tried as administrator and setting for all users, and also as regular user, setting just for current user. Tried rebooting and doing it all again.

Even tried setting compatibility mode to Windows 7.

Windows 10 Enterprise, Version 1803

Re: Will not set as default file manager

Posted: 03 Nov 2018 20:29
by jupe
You could check these registry keys manually, to see if XY is setting them correctly.

HKEY_CURRENT_USER\Software\Classes\Directory\Shell
HKEY_CURRENT_USER\Software\Classes\Drive\Shell

Do they contain the XYPlorer sub keys, and if so are the paths correct?

Re: Will not set as default file manager

Posted: 03 Nov 2018 20:55
by FatIgor
Yes, set correctly in both.

I'll try uninstalling and re-installing. Perhaps that will help.

Re: Will not set as default file manager

Posted: 04 Nov 2018 08:54
by FatIgor
It's partly working...

Dropbox selecting open folder brings up XYplorer, as does creating a new directory on desktop and double clicking it.

From OneDrive, open folder brings up Windows Explorer, Lightroom right clicking an image and selecting show location opens WIndows Explorer, and so does 'Windows Key'+E.

Re: Will not set as default file manager

Posted: 04 Nov 2018 09:06
by highend
From OneDrive, open folder brings up Windows Explorer, Lightroom right clicking an image and selecting show location opens WIndows Explorer
Probably hardcoded, not taking the registry settings into account
Windows Key+E
This has nothing to do with registering something as the default filemanager

If you want to change that, open a command prompt with admin privileges
Execute these commands (ofc you have to adapt the paths if you want to do it only for the current user and not for all and DON't forget to change this "<path to XYplorer>" to the real path of your XYplorer installation / portable folder!

Code: Select all

REG COPY "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command.bak" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /v "DelegateExecute" /f
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /ve /d "<path to XYplorer>\XYplorer.exe" /f

Re: Will not set as default file manager

Posted: 04 Nov 2018 10:19
by admin
highend wrote:
04 Nov 2018 09:06
Windows Key+E
This has nothing to do with registering something as the default filemanager

If you want to change that, open a command prompt with admin privileges
Execute these commands (ofc you have to adapt the paths if you want to do it only for the current user and not for all and DON't forget to change this "<path to XYplorer>" to the real path of your XYplorer installation / portable folder!

Code: Select all

REG COPY "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command.bak" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /v "DelegateExecute" /f
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /ve /d "<path to XYplorer>\XYplorer.exe" /f
Wow, so there it is! Tried it manually and it works well. I renamed DelegateExecute to DelegateExecuteORIG, and added the XYplorer full path to the standard key. Voilà, Win+E opens XYplorer. Thanks, man! :tup:

PS: Even when you click on the Explorer icon it will open XYplorer now!

Re: Will not set as default file manager

Posted: 01 Dec 2018 02:52
by mariovalerio
Hello,
in my case xyplorer doesn't set as default file manager. Every time I restart, the hook in the option "set xyplorer as default manager" is away and windows explorer is again the default file manager.
Can you please help?

Re: Will not set as default file manager

Posted: 01 Dec 2018 08:39
by highend
Post the content of the default value for:

Code: Select all

[HKEY_CURRENT_USER\Software\Classes\Directory\Shell\XYplorer\Command]
[HKEY_CURRENT_USER\Software\Classes\Drive\Shell\XYplorer\Command]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\Shell\XYplorer\Command]
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Drive\Shell\XYplorer\Command]
AFTER starting XY and setting the
"XYplorer is default file manager"
checkmark...

Re: Will not set as default file manager

Posted: 02 Dec 2018 04:16
by mariovalerio
I have also reinstalled XYplorer and then checked the keys in the registry: everything looks ok, but the hook to set XYplorer as default in the Configuration window disappears every time I restart; XYplorer is then replaced from the Windows explorer.
I have tried many times... can you please help?

Re: Will not set as default file manager

Posted: 02 Dec 2018 07:56
by RalphM
highend might be able to help you once you answered his questions above...

Re: Will not set as default file manager

Posted: 02 Dec 2018 23:58
by mariovalerio
sorry, I did not understand that it was a question, but a statement.

In all four keys the value is:
"C:\Program Files (x86)\XYplorer\XYplorer.exe" "%1"
The quotes are included in the key values.

Re: Will not set as default file manager

Posted: 03 Dec 2018 06:59
by highend
Restarting = Windows reboot or a restart of XYplorer (without a Windows reboot)?

What are the default values for:

Code: Select all

HKEY_CURRENT_USER\Software\Classes\Directory\Shell
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\Shell
While
1. XY is running (and the "XYplorer is default file manager" checkmark is set)
2. After a "restart"
?

Additionally, which XY version are you using exactly?

Re: Will not set as default file manager

Posted: 03 Dec 2018 14:17
by mariovalerio
Thank you for your help!

restarting = rebooting

After XYplorer is set as default (checkmark in the configuration):

HKEY_CURRENT_USER\Software\Classes\Directory\Shell
key value is: XYplorer
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\Shell
key value is: XYplorer

after Windows rebooting:
HKEY_CURRENT_USER\Software\Classes\Directory\Shell
key value is: none
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\Shell
key value is: XYplorer

I am using the latest version of XYplorer 19.40.0100

Re: Will not set as default file manager

Posted: 03 Dec 2018 14:29
by highend
The scope for the integration you're using is: Only for the current user, right?

You've used (at least once): For all users of this computer, otherwise HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\Shell
wouldn't be populated with "XYplorer"

So, "<something>" on your computer resets the setting for the current user. This is NOT XYplorer doing it!
There is something else running in the background (probably only on system restart) that does it...

Re: Will not set as default file manager

Posted: 03 Dec 2018 15:03
by mariovalerio
Yes, it happens only for "only for this user".
I have set XYplorer as default for all users too, but I am actually the only user on my computer.
I will set off the running apps on restart one by one to see if one of them causes this. It will take some time.
Will come back asap.
Thank you so much for now!