Page 2 of 2

Re: Will not set as default file manager

Posted: 06 Dec 2018 23:59
by mariovalerio
I have found out cause of this problem. It's Kerish Doctor, actually a very good application for computer optimization.
I guess the app resets the registry key to the standard, i.e. to Windows Explorer, at ever rebooting. Anyway it is definitively this application the cause of the problem; I have tested this many times.
I will now liaise with the support there and inquire further.
Do there is a way to force a change in the registry to be not changed back again?

Re: Will not set as default file manager

Posted: 07 Dec 2018 08:41
by highend
Maintenance - Service - Solving PC Problems - Display Issues - Problems working with files and folders - Folders cannot be opened or only opened improperly
This is one item, that removes XYplorer as the default file manager

If this is carried out automatically on reboot? Probably (but not checked). Why do people use stuff on their PC that they have no control over? oO
Do there is a way to force a change in the registry to be not changed back again?
By trying to change the permissions for the necessary keys.

Re: Will not set as default file manager

Posted: 15 Dec 2018 01:18
by 1024mb
admin wrote:
04 Nov 2018 10:19
highend wrote:
04 Nov 2018 09:06
Windows Key+E
This has nothing to do with registering something as the default filemanager

If you want to change that, open a command prompt with admin privileges
Execute these commands (ofc you have to adapt the paths if you want to do it only for the current user and not for all and DON't forget to change this "<path to XYplorer>" to the real path of your XYplorer installation / portable folder!

Code: Select all

REG COPY "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command.bak" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /v "DelegateExecute" /f
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /ve /d "<path to XYplorer>\XYplorer.exe" /f
Wow, so there it is! Tried it manually and it works well. I renamed DelegateExecute to DelegateExecuteORIG, and added the XYplorer full path to the standard key. Voilà, Win+E opens XYplorer. Thanks, man! :tup:

PS: Even when you click on the Explorer icon it will open XYplorer now!
Can you add an option within the app to do this?
Thanks.

Re: Will not set as default file manager

Posted: 18 Dec 2018 08:04
by admin
Later...

Re: Will not set as default file manager

Posted: 15 Jun 2019 17:39
by ComputerUser
Please add that option, then I will buy it. :-)