18.70.0100 Suspend Auto-Refresh Zombie

Things you’d like to miss in the future...
admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 06 Nov 2018 12:44

Well, thanks for the detailed report, but this does not happen here. The Suspend Auto-Refresh button goes back to normal after the deletion just by itself, and while the copy is still running. Tried USB stick as well. Looking at the code I cannot see why this should not work. Mystery. :|
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

hogaty
Posts: 183
Joined: 19 Apr 2013 21:14

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by hogaty » 06 Nov 2018 15:11

Is autorefresh working in the same manner on NTFS formatted USB stick and in the same manner on FAT32 formatted USB stick ?
Maybe that for FAT32 formatted USB stick is suspend autorefresh state steady state and possible is only refresh during file operations.

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 06 Nov 2018 16:33

I would be surprised, but I don't know for sure. Windows auto-refresh is a black box.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

JohnM
Posts: 220
Joined: 08 Jun 2006 11:59
Location: Tasmania, Australia

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by JohnM » 06 Nov 2018 20:12

A mystery indeed. :?

For the record my tests have all been with NTFS formatted USB drives. I have not tried FAT32.
Windows 8.1 x64
XYplorer 20.90.0303 beta

JohnM
Posts: 220
Joined: 08 Jun 2006 11:59
Location: Tasmania, Australia

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by JohnM » 09 Nov 2018 05:36

I think the problem is related to the "Configuration->File Operations->Enable Background Processing->Copy (can be queued)" option.

If it is ticked, I can reproduce the problem.
If it is not ticked, the problem goes away.

Perhaps the mystery is solved? :wink:
Windows 8.1 x64
XYplorer 20.90.0303 beta

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 09 Nov 2018 16:29

Don't tell me we are talking about Background operations. In earlier posts I said "You start the foreground copy." with a reason...
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 09 Nov 2018 17:36

Well, whatever, that was easy to fix now. Always helps to get the right information... ;)
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

JohnM
Posts: 220
Joined: 08 Jun 2006 11:59
Location: Tasmania, Australia

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by JohnM » 09 Nov 2018 19:35

admin wrote:Don't tell me we are talking about Background operations. In earlier posts I said "You start the foreground copy." with a reason...
Sorry my mistake. :whistle:

I said that I had backgrounded the copy so I thought that meant the copy was a background operation. Obviously, I misunderstood the significance of the term "foreground copy". Why would someone not use background operations? :?
Windows 8.1 x64
XYplorer 20.90.0303 beta

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 09 Nov 2018 20:26

Well, maybe it was my mistake. Just saw that background progress icon in the status bar in your screenshot... :whistle:
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

JohnM
Posts: 220
Joined: 08 Jun 2006 11:59
Location: Tasmania, Australia

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by JohnM » 10 Nov 2018 20:43

Just tried out 19.30.0021 and my problem has gone away :tup: thanks!
Windows 8.1 x64
XYplorer 20.90.0303 beta

avsfan
Posts: 554
Joined: 29 Jun 2006 09:00
Location: Fort Collins, Colorado

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by avsfan » 19 Nov 2018 07:12

I'm seeing something similar. I'm using 19.30.0032. When I'm browsing a network drive on my Synology NAS, the "Suspend Auto-Refresh" option is always ON -- I can't turn it OFF. This includes right after a restart with no background file ops running. This means that every time I update or add a file in that folder, I have to remember to hit Ctrl-R to see the current status of that folder -- really irritating!

I've tried all of the various settings in Configuration->Refresh,Icons,History->Auto-Refresh. Current settings are Auto-refresh ON, Include Network Locations ON, include removable drives ON or OFF (no difference), Refresh during file operations ON, Detect portable devices ON.

Strangely, network drives on other computers don't exhibit this behavior -- just drives on my NAS (I've got a few logical drives on that box, and all of them have this issue).

Any thoughts on why this would be the case?

Thanks!

jupe
Posts: 1285
Joined: 20 Oct 2017 21:14
Location: 2004 x64

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by jupe » 19 Nov 2018 07:22

Not sure about the reason, but if you are interested in a possible workaround you could try and force AutoRefresh on the NAS drive if you want via this tweak (adjust the drive letter to match the NAS, assuming it is mapped to a letter):

Code: Select all

WatchIt=J:\*

avsfan
Posts: 554
Joined: 29 Jun 2006 09:00
Location: Fort Collins, Colorado

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by avsfan » 19 Nov 2018 07:37

Thanks for the reply. I didn't know that tweak, so I just tried it. However, it didn't seem to make any difference -- still had to manually refresh with Ctrl-R to get it to update.

Here is the line from the config file (Drive Z is the one I'm currently working with):
WatchIt=Z:\*|P:\*|V:\*|M:\*

RalphM
Posts: 1366
Joined: 27 Jan 2005 23:38
Location: Cairns, Australia

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by RalphM » 19 Nov 2018 10:44

I've got a Synology NAS myself and my mapped drives on it auto-refresh 99% of the time. Every now and then I encounter a hiccup with it but certainly not often enough to bother me and have me spend time to investigate.
Ralph :-)
(OS: W10 1909 Home x64 - XY: Current beta - Office 2019 32-bit)

admin
Site Admin
Posts: 49053
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: 18.70.0100 Suspend Auto-Refresh Zombie

Post by admin » 19 Nov 2018 11:07

avsfan wrote:
19 Nov 2018 07:12
I'm seeing something similar. I'm using 19.30.0032. When I'm browsing a network drive on my Synology NAS, the "Suspend Auto-Refresh" option is always ON -- I can't turn it OFF.
Sounds weird, cannot explain it. Do you get the same with a fresh instance?

PS: Next version you might see something in the debuglog when you browse such a location:

Code: Select all

dlog;
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Wear a mask! 😷

Post Reply