Page 6 of 6

Re: Drag stops working

Posted: 20 Feb 2017 23:28
by admin
Wired, optical.

Logitech -- always good for trouble many years ago... don't know about today.

Re: Drag stops working

Posted: 22 Feb 2017 14:02
by kinook
admin wrote:1) Tick this: Tools | Customize List | Manual Sorting
2) Drag a file to a new position.
Drag (left & right button) stopped working for me again today. The above does still work. When unticked, I sometimes see the drag icon appear for an instant when I start dragging. I am using a corded mouse (IntelliMouse Optical). Windows 10 Version 1607 (OS Build 14393.693). XY 17.60.

Update: I did not know about the 'Use standard shell drag and drop' option, and after unchecking that, drag works.

Re: Drag stops working

Posted: 22 Feb 2017 14:56
by admin
kinook wrote:Update: I did not know about the 'Use standard shell drag and drop' option, and after unchecking that, drag works.
Looks like this is a common point with all who have reported this issue. (Still I could never reproduce it with this setting.)

Re: Drag stops working

Posted: 24 Feb 2017 15:57
by m48tx
Win7 64-bit XY 17.60.0001

Don, I know you cannot find the reason this is happening, but drag and drop still quits working and at the same time the right click context menu appears to be Windows defaults and the items I have selected for XY - everything else is gone. I can fire up DirOpus and drag/drop/context menu all work just fine. This may be a rather limited problem with the user base, but it is very frustrating.

Update: Drag/drop/context menus work fine in every other program when they fail in XY. Also, it appears file associations in XY are lost. If I double click on any file I get this error dialogue:
ScreenShot00032.jpg
ScreenShot00032.jpg (44.13 KiB) Viewed 522 times

Re: Drag stops working

Posted: 24 Feb 2017 16:19
by admin
1. To turn off Configuration | Shell Integration | Drag and Drop | Use standard shell drag and drop is no option for you?

2. Do you have the FastPictureViewer Codec Pack installed? (Years ago I have seen some issues caused by this that were a bit similar.)

3. File associations in XY are lost: that's totally unrelated to this topic. Please open a new thread and I will try to help.

Re: Drag stops working

Posted: 24 Feb 2017 16:31
by m48tx
Item 1: Drag/drop fails regardless of this setting. When it failed this time, that option was unchecked.

Item 2: No. I have K-Lite Codec Pack installed. I do have PicaView 1.31 installed. I lose PicaView in context menu when drag/drop fails but it still works in DirOpus.

Item 3: The reason I reported this in this thread is that it occurred after drag/drop failed. I have NEVER had this happen before. When I had previous drag/drop fails, I never double clicked a file before I restarted XY.

The failed XY is still open. Anything else you'd like me to check/try?

Re: Drag stops working

Posted: 24 Feb 2017 16:36
by admin
m48tx wrote:Item 1: Drag/drop fails regardless of this setting. When it failed this time, that option was unchecked.
Hm, there goes my theory.

No, there is nothing more to check. I've done what I can. :|

Re: Drag stops working

Posted: 11 May 2019 18:57
by psilosyn
Just wanted to post a potential solution to this problem. I was searching google because this randomly happened after it crashed once. I then checked the autosave settings option because I couldn't believe how much work I lost. Since then I haven't been able to drag and drop. I'm not sure if it happened before or after autosave, so I can't say if it's from the crash or the setting. Disabling autosave does not fix it.

What did fix it for me was disabling the checkmark column.

Re: Drag stops working

Posted: 11 May 2019 19:22
by highend
What is the "checkmark column"?

Re: Drag stops working

Posted: 11 May 2019 19:34
by psilosyn
It's specifically called "Checkbox selection", but are you really asking me that? Sounds pretty damn obvious what I meant.

Re: Drag stops working

Posted: 11 May 2019 19:40
by highend
Checkbox column could have been pretty damn anything, especially user setup custom columns *sigh*

Re: Drag stops working

Posted: 11 May 2019 19:41
by admin
psilosyn wrote:
11 May 2019 18:57
... Since then I haven't been able to drag and drop. ...
That was drag and drop
a) within XYplorer?
b) from XYplorer?
c) to XYplorer?

Re: Drag stops working

Posted: 11 May 2019 20:00
by psilosyn
admin wrote:
11 May 2019 19:41
psilosyn wrote:
11 May 2019 18:57
... Since then I haven't been able to drag and drop. ...
That was drag and drop
a) within XYplorer?
b) from XYplorer?
c) to XYplorer?
All three. I can right click on a file and it re-enables the function so long as I don't click out on blank space, where it disables drag again. Mouse down and drag fails to "pick up" the file.

Re: Drag stops working

Posted: 11 May 2019 21:47
by admin
Ensure this is unticked:
Tools | Customize List | Manual Sorting