Preview 2.0 - Generic Thread

Things you’d like to miss in the future...
sinilill
Posts: 111
Joined: 02 Dec 2013 18:37

Re: Preview 2.0 - Generic Thread

Post by sinilill » 09 Dec 2015 17:34

I guess it has something to do with Preview 2.0, because with older version of XYplorer I didn't get any thumbnails for SVG files :D
Thumbnail backgrounds/transparencys are rendered black, WE vs XY
Image

BTW for SVG thumbnails this needs to be installed https://svgextension.codeplex.com/releases/view/118790

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 09 Dec 2015 19:01

Yep, there is an issue with black background. I get it with TTF thumbnails (true type fonts). I tried a lot but failed up to now. :\

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 09 Dec 2015 20:49

Looks like I fixed it, XYEAH! :beer:

yusef88
Posts: 945
Joined: 28 Jan 2013 03:50
Location: Windows 8.1 32-bit

Re: Preview 2.0 - Generic Thread

Post by yusef88 » 09 Dec 2015 21:59

I wish if a zip file has a file (listed in Text Files Category) get previewed like files end with txt extension

Filehero
Posts: 2306
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Preview 2.0 - Generic Thread

Post by Filehero » 09 Dec 2015 22:00

admin wrote:...., XYEAH! :beer:
:beer: :beer: :beer:

Rather no real bugs, but it might get rise to some confusion/irritation.

1. When FloatingPreview is activated Info Panels preview "suddenly" vanishes (or never appears). At least it looks sort of strange.
NoInfoPreviewWithFloatingPreview.png
NoInfoPreviewWithFloatingPreview.png (706.49 KiB) Viewed 1261 times
2. Only recognized it with my videos (mp4): "Cannot decode" seems to be the default "output". When scrolling through the list of mp4s, there's a constant flickering caused by this default message immediately followed by the display of the the 1st preview frame extracted. Maybe a sort of a time-out can avoid this (hmmm, could require threads?)

Cheers,
Filehero

/E: updated screenshot
Last edited by Filehero on 10 Dec 2015 07:16, edited 1 time in total.

sinilill
Posts: 111
Joined: 02 Dec 2013 18:37

Re: Preview 2.0 - Generic Thread

Post by sinilill » 09 Dec 2015 22:28

Black thumbnails solved :tup: :beer:

Some Excel focus bug is still there. When selecting a Exel file and the preview rendering has finished, both XY and FP windows lose focus, both of the window titles turn gray. Now when I want to preview a second excel file, I have to click once in the list and focus comes back to both windows and click a second time to select the new file. After rendering the preview both windows lose their focus again and so on...

This only happens with Excel files :D
Previewing between Word and Powerpoint files works great, without losing focus :D

hogaty
Posts: 177
Joined: 19 Apr 2013 21:14

Re: Preview 2.0 - Generic Thread

Post by hogaty » 09 Dec 2015 23:44

Exactly it happens by preview of excel files, when no excel file is opened with excel application. It is possible to use arrow keys for change of selected previewed file in the state when focus comes back to both windows; preview window is simultaneously properly rendered.

I would add:
When excel files and preview window are simultaneously opened:
After click on excel file in XYpolrer is focus always transferred to an opened excel file. Without rendering the preview window.
When I minimize all opened excel files, then all works as expected.
sinilill wrote:Black thumbnails solved :tup: :beer:

Some Excel focus bug is still there. When selecting a Exel file and the preview rendering has finished, both XY and FP windows lose focus, both of the window titles turn gray. Now when I want to preview a second excel file, I have to click once in the list and focus comes back to both windows and click a second time to select the new file. After rendering the preview both windows lose their focus again and so on...

This only happens with Excel files :D
Previewing between Word and Powerpoint files works great, without losing focus :D
Last edited by hogaty on 10 Dec 2015 00:48, edited 1 time in total.

Enternal
Posts: 1171
Joined: 10 Jan 2012 18:26

Re: Preview 2.0 - Generic Thread

Post by Enternal » 10 Dec 2015 00:36

"1. When FloatingPreview is activated Info Panels preview "suddenly" vanishes (or never appears). At least it looks sort of strange."
Yeah I get that sometimes. And not only that, there were a few times that the preview tab no longer shows anything aftewards and only started working again after restarting XYplorer. Still don't know how to reproduce it yet so I guess we can sort of ignore it for now.

I did have encountered a bug that I also can't reproduce. This seems to happen on a dual monitor setup. Basically I have XYplorer in my primary monitor and have floating preview in my secondary monitor. If I leave the floating preview open and jump between video files by clicking the files, there were times where the "gut" of the floating preview where it's previewing the video would get torn out and move all the way to the primary monitor. So basically the floating preview window is still there but the video is being previewed somewhere on the primary screen where XYplorer currently is. It's really weird but I can't reproduce it at the moment as well.

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 10 Dec 2015 08:39

Filehero wrote:
admin wrote:...., XYEAH! :beer:
:beer: :beer: :beer:

Rather no real bugs, but it might get rise to some confusion/irritation.

1. When FloatingPreview is activated Info Panels preview "suddenly" vanishes (or never appears). At least it looks sort of strange.
NoInfoPreviewWithFloatingPreview.png
2. Only recognized it with my videos (mp4): "Cannot decode" seems to be the default "output". When scrolling through the list of mp4s, there's a constant flickering caused by this default message immediately followed by the display of the the 1st preview frame extracted. Maybe a sort of a time-out can avoid this (hmmm, could require threads?)

Cheers,
Filehero

/E: updated screenshot
1. That's on purpose. It simply makes things faster to have only one preview done at a time.
2. "Cannot decode" is shown where? I don't see it.

Filehero
Posts: 2306
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Preview 2.0 - Generic Thread

Post by Filehero » 10 Dec 2015 08:44

admin wrote:2. "Cannot decode" is shown where? I don't see it.
When I arrow-down through the list if video files. On every new file selection the message gets displayed for a split second before the preview frame is shown. Unfortunately, I don't have any other videos to cross-check.

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 10 Dec 2015 11:08

Filehero wrote:
admin wrote:2. "Cannot decode" is shown where? I don't see it.
When I arrow-down through the list if video files. On every new file selection the message gets displayed for a split second before the preview frame is shown. Unfortunately, I don't have any other videos to cross-check.
Where?

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 10 Dec 2015 11:52

Conc. the Excel issue. Clearly a bug in the preview handler. Don't know what to do. Set the focus somewhere? But where?

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 10 Dec 2015 11:54

Enternal wrote:"1. When FloatingPreview is activated Info Panels preview "suddenly" vanishes (or never appears). At least it looks sort of strange."
Yeah I get that sometimes. And not only that, there were a few times that the preview tab no longer shows anything aftewards and only started working again after restarting XYplorer. Still don't know how to reproduce it yet so I guess we can sort of ignore it for now.

I did have encountered a bug that I also can't reproduce. This seems to happen on a dual monitor setup. Basically I have XYplorer in my primary monitor and have floating preview in my secondary monitor. If I leave the floating preview open and jump between video files by clicking the files, there were times where the "gut" of the floating preview where it's previewing the video would get torn out and move all the way to the primary monitor. So basically the floating preview window is still there but the video is being previewed somewhere on the primary screen where XYplorer currently is. It's really weird but I can't reproduce it at the moment as well.
1. Fixed now.

2. guts torn out: Yes, I have seen that too on quickly changing a running audio or video. Tried many things, but to no avail. The bugs of others...

Filehero
Posts: 2306
Joined: 27 Feb 2012 18:50
Location: Windows 10 Pro x64

Re: Preview 2.0 - Generic Thread

Post by Filehero » 10 Dec 2015 13:49

admin wrote:But where?
In the preview tab

admin
Site Admin
Posts: 48264
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Preview 2.0 - Generic Thread

Post by admin » 10 Dec 2015 14:57

Filehero wrote:
admin wrote:But where?
In the preview tab
I cannot reproduce it here. :?

Post Reply