File Info Tips with many .avi files causes Xyplorer to hang

Things you’d like to miss in the future...
Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

File Info Tips with many .avi files causes Xyplorer to hang

Post by Chris Wood »

I've recently created a folder containing a lot (22) of large (700MB) avi files. With File Info Tips enabled in XP, merely waving the mouse anywhere in XYplorer when this folder is open in the current tab causes 100% CPU usage and XYplorer hangs (is totally unresponsive) for a few seconds until CPU usage goes back to normal.

I'm using an Athlon64 3000+ with 1GB RAM.
test everything. hold on to the good.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: File Info Tips with many .avi files causes Xyplorer to h

Post by admin »

Chris Wood wrote:I've recently created a folder containing a lot (22) of large (700MB) avi files. With File Info Tips enabled in XP, merely waving the mouse anywhere in XYplorer when this folder is open in the current tab causes 100% CPU usage and XYplorer hangs (is totally unresponsive) for a few seconds until CPU usage goes back to normal.

I'm using an Athlon64 3000+ with 1GB RAM.
Yes, the same can happen with large PDFs. I'm exploiting a system function here and it takes ages until it returns. Don't know why or how to change this.

Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Post by Chris Wood »

Couldn't XYplorer be prevented from fetching info tips for such files?
test everything. hold on to the good.

surrender
Posts: 623
Joined: 23 Oct 2005 08:53
Location: Berlin, Germany

Post by surrender »

Maybe you can uncheck some fields such as duration etc.
or increase the initial delay.

jacky
XYwiki Master
Posts: 3106
Joined: 23 Aug 2005 22:25
Location: France
Contact:

Post by jacky »

Configuration/File Info Tips: enable Show tip only when hovering file icon

That way XY only deals with info tips if you're hovering the icons, so waving the mouse isn't a problem anymore, and you can still get your infotips when you need to!
Proud XYplorer Fanatic

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Post by admin »

jacky wrote:Configuration/File Info Tips: enable Show tip only when hovering file icon

That way XY only deals with info tips if you're hovering the icons, so waving the mouse isn't a problem anymore, and you can still get your infotips when you need to!
Yep. And on top of that I just added a new Tweak. 8) Look for FileInfoTipHoldShift...

surrender
Posts: 623
Joined: 23 Oct 2005 08:53
Location: Berlin, Germany

Post by surrender »

Wow! I like the new "FileInfoTipHoldShift" tweak. :D

Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Post by Chris Wood »

Where? I've downloaded 80.0026 and can't see FileInfoTipHoldShift in my ini file. Can I just add FileInfoTipHoldShift=1 under [FileInfoTips]?

FileInfoTipHoverIcon is good but still causes massive CPU usage if your mouse flicks past an icon (eg. on the way to the tree scrollbar). There should be a delay before anything is read.
test everything. hold on to the good.

surrender
Posts: 623
Joined: 23 Oct 2005 08:53
Location: Berlin, Germany

Post by surrender »

You have to restart app once more.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Post by admin »

Chris Wood wrote:Where? I've downloaded 80.0026 and can't see FileInfoTipHoldShift in my ini file. Can I just add FileInfoTipHoldShift=1 under [FileInfoTips]?
The new key is created when you close 5.80.0026.

Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Post by Chris Wood »

Ah thanks. Unfortunately it doesn't fix the CPU usage problem at all, it still happens even when you aren't pressing shift.
test everything. hold on to the good.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Post by admin »

Chris Wood wrote:Ah thanks. Unfortunately it doesn't fix the CPU usage problem at all, it still happens even when you aren't pressing shift.
Huh? Seems not possible from my point of view. You sure? You have CPU usage without seeing the tip??

Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Post by Chris Wood »

Oh, my bad. Yeah it works thanks.
test everything. hold on to the good.

Chris Wood
Posts: 272
Joined: 25 May 2004 13:01
Location: Wellington, New Zealand
Contact:

Re: File Info Tips with many .avi files causes Xyplorer to hang

Post by Chris Wood »

Just confirming this still happens, and under Vista it seems to crash XY on the second hang. I think Show tip only when hovering should be enabled by default.
test everything. hold on to the good.

admin
Site Admin
Posts: 49999
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: File Info Tips with many .avi files causes Xyplorer to hang

Post by admin »

Chris Wood wrote:Just confirming this still happens, and under Vista it seems to crash XY on the second hang. I think Show tip only when hovering should be enabled by default.
Really? That's bad. Cannot see why it should crash. It certainly does not under XP.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Post Reply