Slow startup due to "Layout Catalog"

Things you’d like to miss in the future...
Post Reply
bitbauer
Posts: 16
Joined: 19 Feb 2018 12:48
Location: Bremerhaven

Slow startup due to "Layout Catalog"

Post by bitbauer » 15 Sep 2020 09:31

Hi,

I'm experiencing an extreme slow startup of xy. It seems that "Layout Catalog" causes this. What can I do?

And why is "RestoreMappedNetworkDrive" not executed asynchronously? I know that this share is only available If I'm connected to my VPN. But this shouldn't prevent xy from resuming startup...

XY ver: 	XYplorer 21.00.0000
OS:     	Windows 10 Professional, 64-bit, Release 1903, Build 18362.1082
Loaded: 	2020-09-15 09:19:22 in 86.071 ms
Threshold: 	10 ms

     0 ms:     147 ms - Start Load
   154 ms:      57 ms - Load Language
   220 ms:      21 ms - Init Controls
   241 ms:      69 ms - Init Graphics
   310 ms:      15 ms - Init Tabs
   325 ms:      32 ms - Create Info Panel
   357 ms:      58 ms - Set Interface Font
   415 ms:      22 ms - Init Panes
   440 ms:  22.018 ms - RestoreMappedNetworkDrive Z:\
22.458 ms:      12 ms - Exist Drive F:\
22.477 ms:      16 ms - Add Drive H:\
22.509 ms:      36 ms - Go Start Path: D:\
22.564 ms:      16 ms - Layout Bars
22.580 ms:  63.315 ms - Layout Catalog
85.895 ms:      78 ms - Layout List
85.973 ms:      39 ms - Show Window
86.012 ms:      58 ms - Layout List
86.071 ms:            - Load Done

MaxiTree: Rows=20, Nodes=20, Expanded=1, Mapped Drives=7
Remember Tree State: Yes (1 stored paths)
Check Existence of Subfolders in Tree: Yes
Pane 1: Items=0/0, Network, Pane 2: Items=21/21, Catalog: Items=36



Thanks for your help!
Last edited by bitbauer on 15 Sep 2020 12:09, edited 1 time in total.

highend
Posts: 9256
Joined: 06 Feb 2011 00:33

Re: Slow startup due to "Layout Catalog"

Post by highend » 15 Sep 2020 10:04

And why is "RestoreMappedNetworkDrive" not executed asynchronously?
No threading.

Anything in your catalog that points to network drives?

Did you already try Configuration | General | Startup & Exit | [x] No network browsing on startup?
One of my scripts helped you out? Please donate via Paypal or paypal_donate (at) stdmail (dot) de

admin
Site Admin
Posts: 49347
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Slow startup due to "Layout Catalog"

Post by admin » 15 Sep 2020 10:38

And untick this:

Configuration | General | Startup & Exit | Reconnect mapped network drives on startup
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

bitbauer
Posts: 16
Joined: 19 Feb 2018 12:48
Location: Bremerhaven

Re: Slow startup due to "Layout Catalog"

Post by bitbauer » 15 Sep 2020 12:05

highend wrote: ↑
15 Sep 2020 10:04
And why is "RestoreMappedNetworkDrive" not executed asynchronously?
No threading.
Yes, I know, but why not?
highend wrote: ↑
15 Sep 2020 10:04
And why is "RestoreMappedNetworkDrive" not executed asynchronously?
Anything in your catalog that points to network drives?
Yes, a lot! Almost every item ;-) But this should not have any impact on the startup performance...
highend wrote: ↑
15 Sep 2020 10:04
And why is "RestoreMappedNetworkDrive" not executed asynchronously?
Did you already try Configuration | General | Startup & Exit | [x] No network browsing on startup?
yes, the checkbox was already checked.

"Layout Catalog" still needs 63 secs to start! What is "Layout Catalog" responsible for?

bitbauer
Posts: 16
Joined: 19 Feb 2018 12:48
Location: Bremerhaven

Re: Slow startup due to "Layout Catalog"

Post by bitbauer » 15 Sep 2020 12:08

admin wrote: ↑
15 Sep 2020 10:38
And untick this:

Configuration | General | Startup & Exit | Reconnect mapped network drives on startup
Did not make any difference :-( At least for the "Layout Catalog" performance...

admin
Site Admin
Posts: 49347
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Slow startup due to "Layout Catalog"

Post by admin » 15 Sep 2020 12:17

bitbauer wrote: ↑
15 Sep 2020 12:08
admin wrote: ↑
15 Sep 2020 10:38
And untick this:

Configuration | General | Startup & Exit | Reconnect mapped network drives on startup
Did not make any difference :-( At least for the "Layout Catalog" performance...
That was for the RestoreMappedNetworkDrive performance. :)
"Layout Catalog" still needs 63 secs to start! What is "Layout Catalog" responsible for?
Hmm, these huge lags can ONLY come from network. What kind of items in your Catalog are these?
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

bitbauer
Posts: 16
Joined: 19 Feb 2018 12:48
Location: Bremerhaven

Re: Slow startup due to "Layout Catalog"

Post by bitbauer » 15 Sep 2020 12:27

admin wrote: ↑
15 Sep 2020 12:17
Hmm, these huge lags can ONLY come from network. What kind of items in your Catalog are these?
Quite normal references to network shares. If I open them in Windows Explorer they show up almost immediately. Even if I click on one of the network locations in xy it lasts up to 60 seconds to get a response. During that I'm not able to use xy anymore.

admin
Site Admin
Posts: 49347
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Slow startup due to "Layout Catalog"

Post by admin » 15 Sep 2020 13:34

bitbauer wrote: ↑
15 Sep 2020 12:27
admin wrote: ↑
15 Sep 2020 12:17
Hmm, these huge lags can ONLY come from network. What kind of items in your Catalog are these?
Quite normal references to network shares. If I open them in Windows Explorer they show up almost immediately. Even if I click on one of the network locations in xy it lasts up to 60 seconds to get a response. During that I'm not able to use xy anymore.
Strange. All those network lag issues have been solved years ago for most users. There must be something special about your system. I will look at it next week (with your help). In the meantime you can play with the settings under Configuration | General | Safety Belts, Network | Network. Especially Fast network enumeration can make a big difference. Under Win10 it should be unticked.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

bitbauer
Posts: 16
Joined: 19 Feb 2018 12:48
Location: Bremerhaven

Re: Slow startup due to "Layout Catalog"

Post by bitbauer » 15 Sep 2020 14:53

Ok, I just updated Windows 10 from version 1909 to 2004 (finally). Don't know if this had to do with the issue but now it works a lot faster...
XY ver: 	XYplorer 21.00.0000
OS:     	Windows 10 Professional, 64-bit, Release 2004, Build 19041.508
Loaded: 	2020-09-15 14:49:09 in 913 ms
Threshold: 	10 ms

     0 ms:     157 ms - Start Load
   157 ms:      22 ms - Init Language
   179 ms:      79 ms - Load Language
   258 ms:      13 ms - Load Settings
   276 ms:      20 ms - Init Controls
   296 ms:      69 ms - Init Graphics
   365 ms:      16 ms - Init Tabs
   381 ms:      34 ms - Create Info Panel
   415 ms:      63 ms - Set Interface Font
   478 ms:      31 ms - Init Panes
   520 ms:      28 ms - Add Drive H:\
   559 ms:      19 ms - Tab Icon Check: \\ats4055\inetpub\wwwroot\
   613 ms:      26 ms - Go Start Path: Dieser PC
   639 ms:      11 ms - Init UDC and KS
   656 ms:      13 ms - Tab Icon Check: \\ats4055\inetpub\wwwroot\
   672 ms:      31 ms - Layout Bars
   703 ms:      93 ms - Layout Catalog
   796 ms:      11 ms - Layout List
   807 ms:      50 ms - Show Window
   863 ms:      47 ms - Layout List
   913 ms:            - Load Done

MaxiTree: Rows=50, Nodes=50, Expanded=4, Mapped Drives=7, Servers=6
Remember Tree State: Yes (5 stored paths)
Check Existence of Subfolders in Tree: Yes
Pane 1: Items=0/0, Network, Pane 2: Items=0/0, Network, Catalog: Items=35



Please consider this problem as solved...otherwise I will come back and report

Thanks for your help!

admin
Site Admin
Posts: 49347
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Slow startup due to "Layout Catalog"

Post by admin » 15 Sep 2020 17:45

Sometimes Windows just needs a reboot. That's an eternal truth it seems.
FAQ | XY News RSS | XY Twitter | Stay home! 🎸 Or wear a mask! 😷

Post Reply