Will not set as default file manager

Things you’d like to miss in the future...
mariovalerio
Posts: 9
Joined: 24 Nov 2015 14:41

Re: Will not set as default file manager

Post by mariovalerio » 06 Dec 2018 23:59

I have found out cause of this problem. It's Kerish Doctor, actually a very good application for computer optimization.
I guess the app resets the registry key to the standard, i.e. to Windows Explorer, at ever rebooting. Anyway it is definitively this application the cause of the problem; I have tested this many times.
I will now liaise with the support there and inquire further.
Do there is a way to force a change in the registry to be not changed back again?

highend
Posts: 7656
Joined: 06 Feb 2011 00:33

Re: Will not set as default file manager

Post by highend » 07 Dec 2018 08:41

Maintenance - Service - Solving PC Problems - Display Issues - Problems working with files and folders - Folders cannot be opened or only opened improperly
This is one item, that removes XYplorer as the default file manager

If this is carried out automatically on reboot? Probably (but not checked). Why do people use stuff on their PC that they have no control over? oO
Do there is a way to force a change in the registry to be not changed back again?
By trying to change the permissions for the necessary keys.
One of my scripts helped you out? Please donate via Paypal or highend (at) web (dot) de

1024mb
Posts: 8
Joined: 14 Dec 2018 23:26

Re: Will not set as default file manager

Post by 1024mb » 15 Dec 2018 01:18

admin wrote:
04 Nov 2018 10:19
highend wrote:
04 Nov 2018 09:06
Windows Key+E
This has nothing to do with registering something as the default filemanager

If you want to change that, open a command prompt with admin privileges
Execute these commands (ofc you have to adapt the paths if you want to do it only for the current user and not for all and DON't forget to change this "<path to XYplorer>" to the real path of your XYplorer installation / portable folder!

Code: Select all

REG COPY "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command.bak" /f
REG DELETE "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /v "DelegateExecute" /f
REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder\shell\opennewwindow\command" /ve /d "<path to XYplorer>\XYplorer.exe" /f
Wow, so there it is! Tried it manually and it works well. I renamed DelegateExecute to DelegateExecuteORIG, and added the XYplorer full path to the standard key. Voilà, Win+E opens XYplorer. Thanks, man! :tup:

PS: Even when you click on the Explorer icon it will open XYplorer now!
Can you add an option within the app to do this?
Thanks.

admin
Site Admin
Posts: 45507
Joined: 22 May 2004 16:48
Location: Cologne, Win 8.1, Win 10
Contact:

Re: Will not set as default file manager

Post by admin » 18 Dec 2018 08:04

Later...

Post Reply