BETA version (with detailed history information)

Get a glimpse of the next XYplorer...
Locked
admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Post by admin »

peterbonge wrote:I know I can delete the ini file. But then I would have to set up all again.
No Peter, please read carefully: run TV3, delete TrackerV3.ini, close TV3. Viola: a fresh clean INI is created!
peterbonge wrote:And I know why you have changed the tabs section. But I don't think that renaming a section is a good idea...
We are talking about changes in the BETA-version here, for me that means work in progress: there's really no need to fatten the app by adding compatibility code between various BETA-builds.

peterbonge
Posts: 320
Joined: 25 May 2004 21:53

Post by peterbonge »

admin wrote:
peterbonge wrote:I know I can delete the ini file. But then I would have to set up all again.
No Peter, please read carefully: run TV3, delete TrackerV3.ini, close TV3. Viola: a fresh clean INI is created!
Ups, yes, I see it now. Works fine. The ini file is now 10% smaller. Thanx!
Regards,
Peter Bonge

My System: Windows 11 Pro, 64-bit, German

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Re: Here's the new BETA

Post by admin »

Download the latest TrackerV3 BETA version (v4.00.0053, 03-may-2005).

Code: Select all

v4.00.0053 - 03.05.05 09:23
    ! You could not delete/copy/move a huge number (ca. > 1000) of files 
      at once: sometimes you got an error message, sometimes even a crash. Fixed.

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Re: Here's the new BETA

Post by admin »

Download the latest TrackerV3 BETA version (v4.00.0054, 03-may-2005).

Code: Select all

v4.00.0054 - 03.05.05 17:26
    ! "Multiple Location Search (via selection in List View)" did not 
      work anymore. Fixed.
    * Now when you do a "Multiple Location Search (via selection in List 
      View)" the selected folders are automatically written into the 
      Location field (separated by " | "). That way they will now be 
      remembered by finding tabs.
    * For internal reasons, the Path column will now always show the full 
      absolute path when you do a "Multiple Location Search", even if 
      all searched locations are direct subfolders of the current tree 
      location.

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Re: Here's the new BETA

Post by admin »

Here's a little experiment: TrackerV3 with XPstyle controls (scrollbars, buttons, etc.)! The archive contains TrackerV3-XPstyle.exe, which you can simply place into your current TrackerV3 folder and run it.
TrackerV3 with XPstyle (04-may-2005).
Questions:
- does it work?
- what happens under Win98?
- do you like it?

Don

Kirby
Posts: 5
Joined: 04 May 2005 14:53
Location: Massachusetts, USA
Contact:

Post by Kirby »

- does it work?

works for me :) it's expecially hard to notice any difference because the tabs aren't skinned, but the buttons, scrollbar, and ratio buttons are.

- what happens under Win98?

Really dunno :lol: but if this is just a .manifest hack, it should run fine on 98

- do you like it?

I like TrackerV3 in general

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Post by admin »

Kirby wrote:it's expecially hard to notice any difference because the tabs aren't skinned, but the buttons, scrollbar, and ratio buttons are.
That's right, the tabs and list column headers are my own and don't carry a theme. Also, there are some graphical buttons on the report tab which aren't skinned, but I plan to redesign them anyway.
Actually I start to like it (yep, it's a manifest hack). Especially the Find Files interface looks real cool now :)

RalphM
Posts: 1593
Joined: 27 Jan 2005 23:38
Location: Cairns, Australia

Re: Experiment XPStyle

Post by RalphM »

admin wrote: Questions:
- does it work?
- what happens under Win98?
- do you like it?
Well I'm not sure what happened, but I couldn't see any difference between 0054 and 0061(XPStyle). :arrow: Therefore I can't rate it, sorry.

Probably because I'm still working with W2K Prof :?: :!:
Ralph :-)
(OS: W10 21H2 Home x64 - XY: Current beta - Office 2019 32-bit - Display: 1920x1080 @ 125%)

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Re: Experiment XPStyle

Post by admin »

RalphM wrote:Well I'm not sure what happened, but I couldn't see any difference between 0054 and 0061(XPStyle).
Probably because I'm still working with W2K Prof.
You probably don't use any XP styles (like "Luna", e.g. blue scrollbars) but the classic interface (grey scrollbars)...
Well, I'm not even sure if W2K has XP styles...

Kirby
Posts: 5
Joined: 04 May 2005 14:53
Location: Massachusetts, USA
Contact:

Re: Experiment XPStyle

Post by Kirby »

admin wrote:Well, I'm not even sure if W2K has XP styles...
nope....W2K has no XP theme support. The only way for themes to be applied for 2000 and lower is for WindowBlinds.

free
Posts: 19
Joined: 17 Apr 2005 13:57

Post by free »

8) Nice scrollbars!

However--It does NOT work at all when xp is set to "classic".
The app seems to exit right away, no process is created. :?

I'm not sure if it's by design so far, only to test the visual add-0ns, but I've seen other apps still function while using/ignoring xp themes
or adding their own.

On the same setup When xp visual style is on, it works as advertised.

Hmmm...
No go on Win ME as well. (and presumably 9x?..)
It works but not a single theme change. Both trackers appear identical.

As for W2K- AFAIK it doesn't have native support for any visual add-ons other than it's alpha transparency settings.

So far I can only see the change between
the 2 in xp with default theme.

peterbonge
Posts: 320
Joined: 25 May 2004 21:53

Post by peterbonge »

Really stylish!

Here it DOES work in classic mode and in style mode. But I haven't found a pc with win98 in my near to test it there...

Nevertheless some buttons and the tabs are still old style. But you already told this. Especially for the tabs the xp style is very important because at the moment it is very difficult to see which one is the active tab. At least with the default blue xp style. With the classic style this is not so extreme.

By the way: When I switch between the classic and the xp style I always have to reset the color of the tabs. It would be nice if there would be an option to have always the default tabs colors. The other colors are no problem.

OT: I was always using the classic style. But now after testing this new version and using the xp style for some time I'm beginning to like the blue xp style...
Regards,
Peter Bonge

My System: Windows 11 Pro, 64-bit, German

free
Posts: 19
Joined: 17 Apr 2005 13:57

Post by free »

peterbonge wrote: Here it DOES work in classic mode and in style mode. ...
If:
-Display properties>Theme-XP -or 'Classic', etc -it works!
But:
If in addition-System properties>Advanced>performance/settings:
Is selected on: "Adjust for best performance" -as opposed to letting windows manage,
Which leaves all other enhancements check boxes 'unchecked' , the process does NOT work!
It exits on load! (no error)
There's a slight cursor movement and -nothing at all.
Saw this in dependency walker:
GetProcAddress(0x5AD70000 [UXTHEME.DLL], "IsAppThemed") called from "MSVBVM50.DLL" at address 0x7410F472 and returned 0x5AD79011.

Unloaded "UXTHEME.DLL" at address 0x5AD70000.
Unloaded "SHLWAPI.DLL" at address 0x77F60000.
Exited "TRACKERV3-XPSTYLE.EXE" (process 0x234) with code 0 (0x0)
Which does not happen with plain trackerv3.exe/0054
OR when advanced/optimised performance settings are not on

(I recently made these adjustments to free up some 'real-estate' since I'm running Virtual PC, but then again I might not be the only one..)
Last edited by free on 05 May 2005 12:09, edited 1 time in total.

free
Posts: 19
Joined: 17 Apr 2005 13:57

Post by free »

free wrote:
peterbonge wrote: Here it DOES work in classic mode and in style mode. ...
If:
-Display properties>Theme-XP -or 'Classic', etc -it works!
But:
If in addition-System properties>Advanced>performance/settings:
Is selected on: "Adjust for best performance" -as opposed to letting windows manage,
:wink: Obviously it was:
"Use visual styles on windows and buttons" check box.
Unckecking it causes tracker-xp to be defunct.

admin
Site Admin
Posts: 52695
Joined: 22 May 2004 16:48
Location: Win8.1 @100%, Win10 @100%
Contact:

Post by admin »

free wrote:However--It does NOT work at all when xp is set to "classic".
Yep, same here. I made some tests and I found the problem must be related to the embedded manifest resource. So I out-bedded it and everything works as expected.
So now: if you want to enjoy XP styles you need the presence of [appname].manifest in the exe path: download new exe and manifest here. If that file is not found or if XP is run with classic style or if you do not have XP, the app should run normally in the old style.

(I'm very surprised that it worked at Peter's machine... no explanation for that).

Locked