Bug: Folders Galore / Memory Leak / Rename

Things you'd like to miss in the future...

Bug: Folders Galore / Memory Leak / Rename

Postby Zardoz2293 » 12 Feb 2012 17:00

  • There has been a (new) phenomena where if a script deals with hundreds of folders hundreds of tab folders get created and there's no easy way to prevent or remove.

  • Related: Memory leak where even after closing all of the tabs, the parent folder of all the tab folders *cannot* be renamed. Somehow XY keeps a handle to one of the folders you worked on even though no tab or reference exists (not in the Tree View, List View). However, this leaked handle reference can be seen in the task manager (searching for the path). The best part is the reference is retained from one XY session to another. It's located in the XYplorer.ini | [mruOpenedItems] which is reporting a Count=64 and item #39 somehow gets opened as a folder in the background. The handle can be disassociated from XY and left as residue with a non-existent process. You either have to kill it or log off/on/reboot to remove it.

  • Related, Folder rename hell where you have to press ESC until you break the can't rename in use dialog message.

Either the above is by design and I don't get it or ...

What are your thoughts?

v10.80.0302
Last edited by Zardoz2293 on 12 Feb 2012 17:36, edited 2 times in total.
Computer/Systems Background = Expert | Windows 7 Ultimate (64-Bit) | 980X @4.5GHz, 24GB @PC3-16000/2000 Mhz, SSD | Dual Monitor
Zardoz2293
 
Posts: 421
Joined: 09 Nov 2011 20:20
Location: USA

Re: Bug: Folders Galore!

Postby PeterH » 12 Feb 2012 17:04

I've got a script creating some folders, but don't get any new tab.

So it's either something about your script, or something about your settings.
We don't know of both...
W7(x64) SP1 German
( +WXP SP3 )
PeterH
 
Posts: 1763
Joined: 21 Nov 2005 20:39
Location: Germany

Re: Bug: Folders Galore!

Postby Zardoz2293 » 12 Feb 2012 17:36

PeterH wrote:I've got a script creating some folders, but don't get any new tab.

So it's either something about your script, or something about your settings.
We don't know of both...

Yes, it's one of THREE possibilities, including a bug. I don't create folders in the script, I rename, renaming a folder shouldn't create a new tab. Further, I get what appears to be sporadic "? /:flat" appearing at the end of the script processing. I suspect most of the above is directly related to having to use indirectly "? /:flat" as an external process to any other command rather than applying "? /:flat" internal to a command.
Computer/Systems Background = Expert | Windows 7 Ultimate (64-Bit) | 980X @4.5GHz, 24GB @PC3-16000/2000 Mhz, SSD | Dual Monitor
Zardoz2293
 
Posts: 421
Joined: 09 Nov 2011 20:20
Location: USA

Re: Bug: Folders Galore / Memory Leak / Rename

Postby Zardoz2293 » 16 Mar 2012 16:04

This appears to be the source of where all my tabs were being created, not from the script, but from the action of moving to other folders to perform the script action again. Thanks for the fix, very much appreciated!!! :D

Code: Select all
v10.90.0103 - 2012-03-15 11:34
    ! Tree: When pressing SHIFT within 300 msecs after moving to a new
      folder by arrow key, it was interpreted as if SHIFT had been
      pressing *while* the arrow key was pressed with the consequence
      that a new tab was opened. Fixed.
Computer/Systems Background = Expert | Windows 7 Ultimate (64-Bit) | 980X @4.5GHz, 24GB @PC3-16000/2000 Mhz, SSD | Dual Monitor
Zardoz2293
 
Posts: 421
Joined: 09 Nov 2011 20:20
Location: USA


Return to Bug Reports



Who is online

Users browsing this forum: No registered users and 0 guests

cron